Misfire Codes, Tryed EVERYTHING... except a solution... please help!!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-13-2011, 11:02 AM   #1
Newb
 
Join Date: Mar 2011
Posts: 12
Misfire Codes, Tryed EVERYTHING... except a solution... please help!!!!

Quick run down of the misfire saga...

Replaced a Oil Pressure Sending Unit a few months ago when the oil gauge went haywire... ripped a wire, spliced and replaced it... no problems.

Few weeks later, check engine light come on, engine dies... open the hood and the Crankcase Vent tube is laying on the crankcase... replace it, and the Crankcase Position Sensor...

Replaced the coil, plugs... still coming on after about 100 miles and if it gets over 65 mph or 3000 rpm....

Replaced the ECM... Engine Light comes on after about 100 miles and over 65 mph/ 3000 rpm...

Replaced the valve springs.... just came on after, you guessed it about 100 miles and over 65 mph...

Just replaced the Cam Position Sensor... betting in 100 miles and up on the highway... it will be back...

It no longer feels like it is misfiring, as it did before the Valve Spring and ECM replacement... Bought an O2 sensor, got under the jeep and then realized there were three more of them...

I am at a loss... wondering if it's a shorting wire? Can't figure out why it doesn't "feel" like it's misfiring, but still throws the codes at a predictable interval...

I am going crazy... and broke.... would love to hear ideas before I go buy three more O2 sensors... What have I missed Jerry Bransford????

Thanks!


sdh796 is offline   Quote Quick Reply
Old 06-13-2011, 12:38 PM   #2
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
It would be helpful if you told us exactly what the code numbers were.

And - Year, engine 4 - 6 etc, miles on it, modifications to the engine, and the plugs you have in it.

__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote Quick Reply
Old 06-13-2011, 01:33 PM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,130
X2. and stop throwing parts at it, a little more time spent diagnosing it will save you a lot of misspent bucks guessing.

And I didn't see plug wires,cap,rotor on your list if it's a misfire condition.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 06-13-2011, 05:14 PM   #4
Newb
 
Join Date: Mar 2011
Posts: 12
Ah... 2002 TJ, with about 75000 miles and the 4.2 straight six.....
sdh796 is offline   Quote Quick Reply
Old 06-13-2011, 05:55 PM   #5
Jeeper

WF Supporting Member
 
6InARowMakesItGo's Avatar
 
Join Date: Aug 2010
Location: right behind you
Posts: 1,863
Quote:
Originally Posted by sdh796 View Post
ah... 2002 tj, with about 75000 miles and the 4.2 straight six.....
4.0?
__________________
2003 Rubicon, 4.0L, 5SPD, Custom 4.75" lift, 33" MT Baja Claws
1999 SE, 2.5L, 5SPD, sold it
PM me for wheeling in and around Northern Illinois
6InARowMakesItGo is offline   Quote Quick Reply
Old 06-24-2011, 11:15 AM   #6
Newb
 
Join Date: Jun 2011
Posts: 2
Hey sdh796:

Feels like we are having the same issue with our Jeeps and mechanics being stumped:

I have a 2002 Wrangler Sport 4.0 with 218,000 miles.

Have been dealing with this same cylinder misfire issue and then fuel injector/cylinder shut down for months now and neither the dealership nor two of my local mechanics seem to have any concrete answers.

Both dealer and local mechanics confirm cylinder misfires followed by the computer shutting down injectors to cylinders.

The dealer claims I need to have top end of the motor re-done. I do not believe them seeing as how they were absolutely convinced on two previous visits that it was the fuel pump (I'm on #3). The dealer kept claiming that the fuel pump was creating the issue. After the 3rd was replaced (by my local shop), the dealer took a look a closer look and then claimed it was not the fuel pump after all. The reason they thought it was a fuel pump issue was due to me bringing the vehicle to them hot (they never told me what condition they needed to vehicle in for accurate diagnostic). After checking it again they stated that two bad cylinders were what was causing them to give me the pressure loss in the fuel pump area. This is were they suggested machining the heads.

What has been tried to date:

Coil pack (aftermarket)
Plugs & wires
Crankshaft sensor
Carbon treatment
3 fuel pumps (dealer pump on there now).
Local shop pulled valve cover and stated that the motor looked "spotless"

Local shop did not notice significant compression loss in cylinders as claimed by dealer.

This has been a very inconsistent problem. At first (January) the cylinder shut down only occurred at + 65 miles per hour. Recently it has gotten much worse - Flashing check engine light in the morning within first two miles of travel. Cylinder shut down during city driving. This issue is happening in conjunction with hard starting (having to crank vehicle twice to get it to start). The hard starting is inconsistent as well. For weeks before bringing it into my local shop it was starting hard. After the visit to the shop it started fine.

Both my local mechanics are just about out of answers. they are pretty convinced though that I do NOT need to have the motor re-done (as suggested by dealer).
Brenonline is offline   Quote Quick Reply
Old 06-24-2011, 04:49 PM   #7
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
If BOTH of you would tell us the EXACT code you are getting we may be able to help. Just saying misfire is not specific enough. There are quite a few misfire codes, each one has a different reason for it and different fixes.

And --- Plugs - neither of you said anything about WHAT PLUGS you are using - brand and part number, and age is important.

Specific and exact Code numbers please.

__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote Quick Reply
Reply

Tags
bransford , codes , misfire , sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire problem beejman25 TJ General Discussion Forum 0 02-22-2011 07:54 PM
misfire codes runs badly RubyMax3388 TJ Tech Forum 8 12-20-2010 05:42 PM
Misfire question CenARJeepChick TJ Tech Forum 4 09-01-2010 03:18 PM
Runing rough, idle rough, cylinder #4 misfire spdrcrpete TJ General Discussion Forum 13 06-02-2008 01:32 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM



» Featured Product

All times are GMT -5. The time now is 01:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC