No Fuse blinking on the odometer - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 08-07-2012, 12:37 AM   #1
Join Date: Jul 2012
Posts: 39
No Fuse blinking on the odometer

SO my jeep died today and long story short I replaced the battery (much needed), it reset the idle control sensor and died again but the weird part was when I turned her there was no hint of electricity, I thought I fried her. we sat there for about 30 min and she decided to show some life and cranked up just fine, but amidst the confusion while i was checking fused for signs of electrical problems, I think I pulled too hard on the fuel 10A fuse and separated the medal connector piece from the yellow portion of the fuse box. This in turn makes the 10A fuse not stick in and I think is the reason why it is showing no fuse. My question is, is this a tough fix or expensive? can I just pop that yellow piece (with all the fuses in it) off and reconnect the medal connector so all will be right in this world? thanks

0iii0 is offline   Quote
Old 08-07-2012, 06:14 AM   #2
jefferyfghezzi's Avatar
Join Date: Jan 2011
Posts: 659
A picture would help.
jefferyfghezzi is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:04 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC