No gauges no dash ???? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-04-2012, 06:47 AM   #1
Jeeper
 
Join Date: Feb 2012
Posts: 32
No gauges no dash ????

Strange event happened this past weekend.
I jumped into the TJ it started fine, but not a single gauge on the dash worked...
The idiot lights all momentarily came on and everything else electrical worked, but not a singe gauge...
NO:
speedo, tach, oil pressure, temp, battery gas. No even the odometer worked.
I drove about 8 miles none of the gauges worked and the mileage for the trip did not register.
Stopped at store 1 restarted, no gauges worked, I pulled the 10AMP fuse for the gauges , it looked good. Restarted, none of the gauges worked.
I drove to store 2. Restarted, none of the gauges worked
I drove to store 3. Restarted, all of the gauges worked.
I drove to a restaurant, restarted and all of the gauges worked.

Any idea what is going on? Bad ground? If so which one?

Thanks
Rich

I drove home and now it logged the 8 miles home on the odometer

Fortune is offline   Quote Quick Reply
Old 09-04-2012, 07:57 AM   #2
Jeeper
 
Beachcomber's Avatar
 
Join Date: Jan 2010
Location: NJ during the week Delaware on most weekends
Posts: 346
I had a problem a few weeks ago when the dash and gauges didn't work but the speedo worked. It was caused buy the key not returning from the start position. The speedo is not electrical so it should still work.

Beachcomber is offline   Quote Quick Reply
Old 09-04-2012, 08:08 AM   #3
Jeeper
 
Trevor C's Avatar
 
Join Date: Jul 2012
Location: Wildwood, FL
Posts: 238
That happend to me, I just hit the top of the dash and they turned right back on lol
Trevor C is offline   Quote Quick Reply
Old 09-04-2012, 10:32 AM   #4
RossRacing7x

WF Supporting Member
 
Kota7x's Avatar
 
Join Date: Jul 2011
Location: 93105, 92677, 92004
Posts: 1,610
Might want to check the plug in the back of the cluster. Might have come loose.
__________________
Sure you can follow... If you can keep up!!!
- 2004 Jeep Wrangler LJ 4.0
Kota7x is offline   Quote Quick Reply
Old 09-05-2012, 05:53 AM   #5
Jeeper
 
LiftedTj's Avatar
 
Join Date: Oct 2011
Location: Toledo, Oh (Where Jeeps are born THEN raised)
Posts: 440
You need to take the speedo out and clean and slightly tweak the male connectors to get a better fit when re-installing the speedo
__________________
'Cuz im Mr. OOGIE BOOGIE and you ain't going NO WHERE.
LiftedTj is offline   Quote Quick Reply
Old 09-05-2012, 09:08 AM   #6
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 1,976
Pull the dash cluster and clean/tighten the contacts.
Wattapunk is offline   Quote Quick Reply
Old 09-05-2012, 10:00 AM   #7
Jeeper
 
mrbat23's Avatar
 
Join Date: Jan 2012
Location: illinois
Posts: 310
Images: 3
check this ground, it caused the same problem in my jeep. Its on the firewall.
mrbat23 is offline   Quote Quick Reply
Old 09-06-2012, 08:09 AM   #8
Jeeper
 
Join Date: Feb 2012
Posts: 32
Thanks guys.
Will follow up on the leads.

Rich

Fortune is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC