Not changing into 4H or 4L - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-09-2012, 02:08 AM   #1
Jeeper
 
ImpTroop's Avatar
 
Join Date: Mar 2012
Location: Eagle River, AK
Posts: 20
Not changing into 4H or 4L

(To start off with, im sorry if I posted this in the wrong section)

Hello all! Yesterday a friend and I went to work changing my cat-back on my jeep. We finished up and now it wont change into 4H or 4L. The lever moves very easily between the settings, but I dont hear any linkage (right term?) moving and the light on the dash does not go on.

The only things we disassembled was the exhaust and took off the skid plate. One thing that happened is when the tranny was lowering after we took the skid plate off, the rod with the "u joint" popped out. the part with the little rubber boot on it that i think slips into the tranny. we just popped it right back in. the jeep drove perfect when i took it out for a spin, but when i tried to put it in 4H to get over some snow, nothing happened. Is there anything you think could had slipped or undid to make this happen? Thanks very much!!

Also, my jeep is an 06, 6 speed 4.0

Sorry if my terms are incorrect; Im fairly new at car mechanics

ImpTroop is offline   Quote Quick Reply
Old 04-09-2012, 02:14 AM   #2
Jeeper
 
H8-roads's Avatar
 
Join Date: May 2011
Location: Granada hills
Posts: 534
Images: 1
Sounds like the t case linkage. Do you have any pics? Sure you popped back in the right place?

__________________
more than just a jeep.........
H8-roads is offline   Quote Quick Reply
Old 04-09-2012, 03:01 AM   #3
Jeeper
 
ImpTroop's Avatar
 
Join Date: Mar 2012
Location: Eagle River, AK
Posts: 20
i will get some pictures up tomorrow if it will help. yea im sure it went to the right place; it didnt slide out completely, just a little as the interconnect dropped some so as i pushed it back up i made sure it went back in.
ImpTroop is offline   Quote Quick Reply
Old 04-09-2012, 04:54 AM   #4
Jeeper
 
aaron 06tj's Avatar
 
Join Date: Feb 2012
Location: ooltewah
Posts: 63
this happened to me it is the tcase linkage there is a bracket mounted on the bottom of the tub that it slides into andt it poped out when i did my exhaust. i will try and get some pics later today. The bracket has 4 10mm bolts under the carpet on the driver side by the shifter.
aaron 06tj is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TRUE or FALSE caseyjoe Off-Topic 7219 04-16-2014 10:10 AM
Rear Main Seal or Oil Pan leak? Crazyflyingplastics TJ Tech Forum 36 12-08-2012 09:19 PM
Anyone a Lineman or climb utility poles? wvhillbilly General Jeep Discussion 11 04-12-2012 09:27 PM
Lift ::::take it somewhere/or do it yourself? I The youngin and jeeper YJ Tech Forum 16 04-10-2012 01:41 PM
Tire Pressure Sensor, quick fix or problem? Jordan2 JK General Discussion Forum 11 04-09-2012 03:19 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC