O2 sensor failure csuses? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-14-2010, 11:37 AM   #1
Jeeper
 
4x4junkie's Avatar
 
Join Date: Aug 2010
Posts: 79
O2 sensor failure csuses?

99 TJ 2.5 Liter
Ok what can cause the O2 sensor to fail?? Besides coolant leaking into engine
I've already changed the number 1upper sensor twice and it keeps failing after 2-3 days

I'm going crazy, just had engine rebuilt and blown head gasket work completed.

I can't figure it out need help!!!

__________________
Brian Ochoa
4x4junkie is offline   Quote
Old 12-14-2010, 11:44 AM   #2
Jeeper
 
Schmo's Avatar
 
Join Date: Jul 2007
Location: SoCal
Posts: 1,586
When my cat failed, it took out the O2 sensor. Pretty common issue from what I've seen with the cats not holding up, and apparently when they start to go, they can damage the sensor. Not sure if that has anything to do with your issue though.

__________________
Bite the hand that feeds you . . . you've had more than enough to eat already.
Schmo is offline   Quote
Old 12-14-2010, 12:22 PM   #3
Jeeper
 
4x4junkie's Avatar
 
Join Date: Aug 2010
Posts: 79
Quote:
Originally Posted by Schmo
When my cat failed, it took out the O2 sensor. Pretty common issue from what I've seen with the cats not holding up, and apparently when they start to go, they can damage the sensor. Not sure if that has anything to do with your issue though.
Wouldn't the back sensor go bad too??
Code is only telling me front one the number 1.
__________________
Brian Ochoa
4x4junkie is offline   Quote
Old 12-15-2010, 06:27 PM   #4
Jeeper
 
Schmo's Avatar
 
Join Date: Jul 2007
Location: SoCal
Posts: 1,586
Sorry man, that's the only experience I've had with O2 sensors . . . anything thing else and I'd be talking out my ass.
__________________
Bite the hand that feeds you . . . you've had more than enough to eat already.
Schmo is offline   Quote
Old 12-15-2010, 06:48 PM   #5
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
Why do you think it's a sensor failure? Misinterpreting the code?

What code are you getting?
rrich is offline   Quote
Old 12-15-2010, 10:10 PM   #6
Jeeper
 
4x4junkie's Avatar
 
Join Date: Aug 2010
Posts: 79
Quote:
Originally Posted by rrich
Why do you think it's a sensor failure? Misinterpreting the code?

What code are you getting?
Well it's not a code the expensive computer diagnostic my uncle has actually tells us it's o2 sensor # 1.
__________________
Brian Ochoa
4x4junkie is offline   Quote
Old 12-15-2010, 10:19 PM   #7
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
What are the symptoms you are experiencing? Trouble running?

Failing how? What tests?

After so many sensors I'd think something else is making it look like it's failing, if at all.
rrich is offline   Quote
Old 12-17-2010, 08:26 PM   #8
Jeeper
 
4x4junkie's Avatar
 
Join Date: Aug 2010
Posts: 79
Quote:
Originally Posted by rrich
What are the symptoms you are experiencing? Trouble running?

Failing how? What tests?

After so many sensors I'd think something else is making it look like it's failing, if at all.
Engine shakes a little and I hear a weird rattle coming from the exhaust.
__________________
Brian Ochoa
4x4junkie is offline   Quote
Old 12-17-2010, 09:38 PM   #9
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
What is his scanner showing for that O2 sensor- voltages, cross counts etc?

rrich is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:47 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC