o2 sensor problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-02-2011, 11:54 AM   #1
Newb
 
Join Date: Oct 2011
Location: cedar rapids,iowa
Posts: 3
o2 sensor problems

this has been asked a million times but i'll ask a hope soeone can help. I have a 06 wrangler x 4l that gave me a p0151 code with a ntk part for sensor 2/1 . replaced it with a bosch sensor . failed again but with a new code p0152 bank 2 sensor 1 . thought it was a defective part so i replaced again went 50 miles cel came on with same p0152 code also it has a code p2096 with p0152, any help ? Bill

wind4543 is offline   Quote
Old 11-02-2011, 12:13 PM   #2
Jeeper
 
Join Date: Mar 2011
Location: Nw Indiana
Posts: 37
Replace it with an OEM sensor, chrysler's seem to be picky.
Teo74 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:39 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC