OBDII Code 2096 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-17-2011, 08:03 PM   #1
Newb
 
Join Date: Jul 2011
Location: Aruba
Posts: 5
OBDII Code 2096

Hey Fellow Jeep Owners!

Last thursday I bought my first Wrangler. Its form 2005, and for Aruba, in a quite good condition. Ofcourse there are some things to do, but nothing a bit of TLC can't take care of.

Except for 1 thing, that is the OBDII code 2096 that comes up. The story is as follows: I testdrove it, no Check Engine Light comes on. The two days after, nothing happens. And today, the CIL comes up. I checked the error code (by turning the key 3-times), which read 2096. I do not have a service manual, so I don't know what to make of this code? Does anyone have a clue what this means?

I heard the CIL comes up after fueling and not closing the cap properly, but that has a different code I believe.

Thank you in advance,

Marnix

Marnix is offline   Quote Quick Reply
Old 07-17-2011, 08:12 PM   #2
Jeeper
 
Scoob's Avatar
 
Join Date: Aug 2005
Location: Iowa
Posts: 1,790
p2096 - post catalyst fuel trim system low limit

Possible Causes
EXHAUST LEAK
ENGINE MECHANICAL PROBLEM
1/2 O2 SENSOR
(K141) O2 SENSOR 1/2 SIGNAL CIRCUIT
(K299) O2 1/2 HEATER CONTROL CIRCUIT
(K904) O2 DOWNSTREAM RETURN CIRCUIT
FUEL CONTAMINATION

__________________
Scoob
Scoob is offline   Quote Quick Reply
Old 07-17-2011, 08:34 PM   #3
Newb
 
Join Date: Jul 2011
Location: Aruba
Posts: 5
Thx for your quick reply. I'll have a look at the exhaust first, although it doesn't make a leaking sound. I'll give the wiring to the sensors a check as well. I really hope it's not the O2 sensors, because I have the feeling those are expensive (as they are on other cars, like the ones I had to replace on my 300ZX). The engine itself runs smooth, so I don't think I'm experiencing a mechanical problem.
Marnix is offline   Quote Quick Reply
Old 07-17-2011, 08:38 PM   #4
Jeeper
 
Rubicon2's Avatar
 
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
About $35.00 or so per sensor. They were probably expensive on your 300ZX because it's an import and the parts have to come from halfway around the world.
__________________
DO OR DO NOT... THERE IS NO TRY.
Rubicon2 is offline   Quote Quick Reply
Old 07-17-2011, 08:41 PM   #5
Jeeper
 
Scoob's Avatar
 
Join Date: Aug 2005
Location: Iowa
Posts: 1,790
Quote:
Originally Posted by Rubicon2 View Post
About $35.00 or so per sensor. They were probably expensive on your 300ZX because it's an import and the parts have to come from halfway around the world.
LOL, I think he is already half way around the world
__________________
Scoob
Scoob is offline   Quote Quick Reply
Old 07-17-2011, 08:42 PM   #6
4 Little Squirrels

WF Supporting Member
 
ellman605's Avatar
 
Join Date: Oct 2010
Location: Lewisville, TX
Posts: 718
I got that yesterday after driving through a lot of dust in the air. Reset the code and light went off, code hasnt come back. Had the same code 3 months ago, reset, and just came on yesterday after that huge amount of dust.

Just my $.02
__________________
Elliott
'99 TJ Sport: 4.0L 12X,XXX Miles, 32RH Auto, 3.5" Suspension, 1.25"BL, SYE, D35 4.10 D30 Aussie Locked.

2013 CB500X: The toy
ellman605 is offline   Quote Quick Reply
Old 07-17-2011, 08:46 PM   #7
Newb
 
Join Date: Jul 2011
Location: Aruba
Posts: 5
Haha, well, I'm close to the US now, that should save a bit on the parts ;-). 35$ isn't that bad really.

@ellman, thx for the tip, it is quite dusty here at times. But how do I reset the code, just disconnect the battery?
Marnix is offline   Quote Quick Reply
Old 07-17-2011, 09:37 PM   #8
Jeeper
 
Rubicon2's Avatar
 
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
Quote:
Originally Posted by Scoob

LOL, I think he is already half way around the world
lol oops. I can't see entire profiles on my phone.
__________________
DO OR DO NOT... THERE IS NO TRY.
Rubicon2 is offline   Quote Quick Reply
Old 08-02-2014, 08:11 PM   #9
Newb
 
Tim R's Avatar
 
Join Date: Jul 2014
Location: Trade City, Pa
Posts: 6
Been having this problem with my '05 TJ. but it happens only after a oil change. About 200 miles after I change oil the check engine light comes on. The code is 2096. I reset the code and it stays off till the next oil change. Has me confused. Does not affect how it runs.

Tim R is offline   Quote Quick Reply
Reply

Tags
cil , obd2 , obdii

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best explanation of OBDII Code read. Marsmonkey12 General Jeep Discussion 0 01-30-2011 08:16 PM
P0700 code, what to do and why only this code? Dixit TJ General Discussion Forum 18 07-10-2010 11:31 AM
OBDII code Jeepmanj20 TJ Tech Forum 0 11-28-2009 11:37 PM
obdII code p0342 robs04wrangler TJ General Discussion Forum 0 10-21-2009 06:57 PM
OBDII Code Help Again.................Please Scooby TJ Tech Forum 6 03-12-2007 06:26 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC