Oil Pump Drive Gear - HELP PLEASE! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-23-2011, 02:59 AM   #1
Jeeper
 
Rolf's Avatar
 
Join Date: Sep 2011
Location: South Africa
Posts: 941
Oil Pump Drive Gear - HELP PLEASE!

I am in desperate need for some help.

I have been getting code P0340 intermittantly over the last couple of days.

So last night I decided to remove the Cam Position Sensor and see if I can see any visible problem. On removal I could see that some tool tightened the bracket for the oil pump drive too tight at some point so the rim of the drive has a piece missing - not a major disaster I would think as it does look like the shaft is still sealing well against the gasket. This however is not my problem.

I removed the oil pump drive from the block to check the problematic drive gear that I have read about, noting the position before I removed it.

After reinstalling everything it won't start. The engine turns over but nothing. I must have done somthing wrong in the process it seems so I recon the CMP sensor relationship must be reestablished, as the manual states.

I have read the complete instructions in the manual but something does not make sense to me. You are supposed to install a toothpick through the drive housing and the hole in the pulse ring. Not a problem. The problem comes with what needs to follow. You are supposed to remove the coil rail and spark plug #1 and rotate the crank, etc. Still in theory not a problem.

This is what needs to happen next:

1. Install oil pump drive into engine while aligning into slot on oil pump.
2. Rotate oil pump drive back to its original position and install hold-down clamp and bolt.
3. Remove toothpick from housing.

According to me step 2 is not possible with the toothpick still there. As soon as you rotate the oil pump drive housing the toothpick will break. Am I missing something?

This is my main mode of transport so I need some advice please.

__________________
2003 Wrangler Sahara 4.0 42rle D30/D44
Front: 2" BDS coils + JKU shocks
Rear: 2" BB + Zone Nitro shocks
Zone 1.25" BL + 1" MML, UCF LoPro
32" BFG AT on 16" Racing Hart
Ramsey Pro Plus 6000, IPF 900s 130W
Rolf is offline   Quote Quick Reply
Old 11-23-2011, 03:22 PM   #2
Jeeper
 
brokejeep's Avatar
 
Join Date: Oct 2009
Posts: 257
You should be able to bring the engine to tdc & reinstall opda with a pin aligning the tone wheel to the housing. The screw holes that hold the plastic cover on should be parallel withe the side of the engine block & valve cover. I have removed mine twice. Both times I rolled the engine with a wrench on the crank till the hole in the tone wheel lined up with the one in the housing. Put in the pin unhooked the wires & removed.

brokejeep is offline   Quote Quick Reply
Old 11-24-2011, 11:17 AM   #3
Jeeper
 
paulpa's Avatar
 
Join Date: Oct 2011
Location: CT.
Posts: 35
Quote:
Originally Posted by Rolf View Post
I am in desperate need for some help.

I have been getting code P0340 intermittantly over the last couple of days.

So last night I decided to remove the Cam Position Sensor and see if I can see any visible problem. On removal I could see that some tool tightened the bracket for the oil pump drive too tight at some point so the rim of the drive has a piece missing - not a major disaster I would think as it does look like the shaft is still sealing well against the gasket. This however is not my problem.

I removed the oil pump drive from the block to check the problematic drive gear that I have read about, noting the position before I removed it.

After reinstalling everything it won't start. The engine turns over but nothing. I must have done somthing wrong in the process it seems so I recon the CMP sensor relationship must be reestablished, as the manual states.

I have read the complete instructions in the manual but something does not make sense to me. You are supposed to install a toothpick through the drive housing and the hole in the pulse ring. Not a problem. The problem comes with what needs to follow. You are supposed to remove the coil rail and spark plug #1 and rotate the crank, etc. Still in theory not a problem.

This is what needs to happen next:

1. Install oil pump drive into engine while aligning into slot on oil pump.
2. Rotate oil pump drive back to its original position and install hold-down clamp and bolt.
3. Remove toothpick from housing.

According to me step 2 is not possible with the toothpick still there. As soon as you rotate the oil pump drive housing the toothpick will break. Am I missing something?

This is my main mode of transport so I need some advice please.
rotate the oil pump wth a long srewdriver,not the shaft on the assembly,the pump itself.
paulpa is offline   Quote Quick Reply
Old 11-24-2011, 01:58 PM   #4
Jeeper
 
Rolf's Avatar
 
Join Date: Sep 2011
Location: South Africa
Posts: 941
Thanks Paul, I managed to figure that out today and she now purrs again
__________________
2003 Wrangler Sahara 4.0 42rle D30/D44
Front: 2" BDS coils + JKU shocks
Rear: 2" BB + Zone Nitro shocks
Zone 1.25" BL + 1" MML, UCF LoPro
32" BFG AT on 16" Racing Hart
Ramsey Pro Plus 6000, IPF 900s 130W
Rolf is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power to the fuel pump vikessoftball YJ Tech Forum 11 04-16-2012 10:56 PM
Oil pump drive assembly failure? paulpa TJ General Discussion Forum 2 10-25-2011 04:46 AM
97 wrangler no start got spark no power to fuel pump 97rangler TJ General Discussion Forum 12 05-11-2011 11:41 PM
Oil pump drive gear! (Found supplier) CaseyB TJ General Discussion Forum 6 05-02-2011 09:39 AM
Engine oil pump drive gear Chack7 TJ Tech Forum 1 01-31-2011 08:16 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:58 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC