OK I need some help fast - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-01-2012, 07:22 PM   #1
Jeeper
 
Surfordie's Avatar
 
Join Date: Aug 2011
Posts: 52
OK I need some help fast

The other day I changed my sparkplugs with no problem (Autolite 985 gapped to .35) as soon as i started it up i had an obvious misfire. I then replaced the wires and still had a miss. Pulled one plug that i suspected because i had trouble putting it in and the gap was messed up so i fixed that. Now it only misses at start up but when im at a stoplight it will die on my everytime unless i put it in park or keep my RPMs up. What could it be?

Surfordie is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration problems under "load"... Help please Shtewy YJ Tech Forum 4 05-20-2014 12:12 PM
HELP! tryin to build stoker ? bamaboyz71 WF New Member Check In 4 04-02-2012 04:30 AM
transmission help nolanator TJ General Discussion Forum 3 04-01-2012 05:39 PM
I need your help. A Deasoninc General Jeep Discussion 0 04-01-2012 05:05 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:18 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC