Please give me some quick assistance... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-19-2011, 11:15 AM   #1
Newb
 
Join Date: Apr 2011
Posts: 5
Please give me some quick assistance...

This is important as I have the jeep for sale and showing it Saturday & need to know how to proceed and if this is an expensive problem to repair.

I have a cruisecontrol issue.....problem is...the cruise turns on, lights up in the instrument panel but will not engage without pushing the set buttons numerous times in succession. Once it sets, all the other buttons work properly. The cruise will speed up, down, and even resume. The problem is with the initial set of the cruise. It seems like a "on" switch problem but I don't know if you can replace part of the unit or not. Has anyone ever run into this issue, if so what did you do?

JudyM is offline   Quote
Old 10-19-2011, 11:53 AM   #2
Jeeper
 
C.L.'s Avatar
 
Join Date: Mar 2011
Location: North NJ
Posts: 2,156
The link goes nowhere. Funny behavior from the steering wheel buttons is usually related to the clock spring. I have heard that hitting the horn will reset something in there on the JK and resolve some issues; not sure if that works on TJs as well. You ARE going to be working in the vicinity of the airbag if you change the clock spring yourself, so be sure to disconnect the battery and pull the airbag fuse before diving in.

C.L. is offline   Quote
Old 10-19-2011, 12:21 PM   #3
Jeeper
 
jeepinmike's Avatar
 
Join Date: Sep 2011
Location: East Amherst NY
Posts: 225
Quote:
Originally Posted by JudyM View Post
This is important as I have the jeep for sale and showing it Saturday & need to know how to proceed and if this is an expensive problem to repair.

I have a cruisecontrol issue.....problem is...the cruise turns on, lights up in the instrument panel but will not engage without pushing the set buttons numerous times in succession. Once it sets, all the other buttons work properly. The cruise will speed up, down, and even resume. The problem is with the initial set of the cruise. It seems like a "on" switch problem but I don't know if you can replace part of the unit or not. Has anyone ever run into this issue, if so what did you do?

My LJ sometimes takes a few times to set....usually pushing a little harder on the button gets it to work... don't use it alot so I really have not played with it much. Probably a crappy contact in the switch, the switches are easy to replace.
__________________
fuel in my veins, mountains on the brain......
06 Unlimited - 2.5 ish lift, 31" KM2, working on it.
BUFFALO NY JEEPERS
jeepinmike is offline   Quote
Old 10-19-2011, 02:15 PM   #4
Jeeper
 
wedu22's Avatar
 
Join Date: Sep 2011
Location: SECT
Posts: 1,015
Images: 6
Like Jeepinmike, I too had to push more than once at times. Got tired of doing that & sprayed electronic contact cleaner (after disconnecting battery). Fixed it first try & dries quickly. Should be able to pick up in auto part store.
__________________
75k miles (6/28/13) 04 Sport, 4.0L 5spd, D44/30-186mm front, 31" Goodyear Wrangler MR/T
Alice the Beagle - "I wanna ride in the Jeep, I'll give you my bone."

- Semper Paratus
You know you drive a TJ when you have the parts for the mod, the right tools for the job, a BFH & still need a Sawzall to get the job done!
wedu22 is offline   Quote
Old 10-19-2011, 11:16 PM   #5
Newb
 
Join Date: Apr 2011
Posts: 5
what exactly did you spray electronic contact cleaner on? also, aren't there different kinds of this cleaner..what kind should I use?
JudyM is offline   Quote
Old 10-19-2011, 11:44 PM   #6
Jeeper
 
WaterDR's Avatar
 
Join Date: Feb 2011
Posts: 1,339
Contact cleaner is essentially alcohol. When you have button problems like this it is probably dirt and grime in combo with vinyl treatment getting on the copper contacts of the switch. Alcohol evaporates and leaves no residue.
WaterDR is offline   Quote
Old 10-20-2011, 02:01 PM   #7
Jeeper
 
wedu22's Avatar
 
Join Date: Sep 2011
Location: SECT
Posts: 1,015
Images: 6
Quote:
Originally Posted by JudyM View Post
what exactly did you spray electronic contact cleaner on? also, aren't there different kinds of this cleaner..what kind should I use?
I sprayed it in the space between the cruise control button and steering wheel. There are different kinds. I have always used CRC Electrical Contact Cleaner (tip I learned from the Electronics Dept while in the military). Basically, in a nut shell it is a:
Electrical Contact Cleaner
A petroleum distillate/alcohol-based precision cleaner
Quick drying
Leaves no residue
Safe on all plastics
Effectively removes soil and other contaminants from electrical and electronic components
Ideal for applications where lower flashpoint solvents can be used

__________________
75k miles (6/28/13) 04 Sport, 4.0L 5spd, D44/30-186mm front, 31" Goodyear Wrangler MR/T
Alice the Beagle - "I wanna ride in the Jeep, I'll give you my bone."

- Semper Paratus
You know you drive a TJ when you have the parts for the mod, the right tools for the job, a BFH & still need a Sawzall to get the job done!
wedu22 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 wrangler 4cyl. feeles like flooding when give it gas osucowpoke YJ Tech Forum 11 07-05-2011 10:06 AM
Just a quick pic... Owen_TJ Tires & Wheels 5 11-05-2010 07:34 PM
quick disconnect install & removing front sway bar Curt93acw TJ Tech Forum 3 10-24-2010 07:11 PM
quick disco GoodLife TJ Tech Forum 18 05-08-2009 03:25 PM
Best Quick Disconnects??? jgano23 TJ General Discussion Forum 33 01-04-2009 01:41 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC