possible elecrical...need help!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-25-2012, 08:35 PM   #1
Newb
 
Join Date: Nov 2011
Posts: 3
possible elecrical...need help!!

97 TJ 2.5 standard. So frustrated!!! when I hit a bump engine looses power then recovers quickly. When backing up losses power, when i push the clutch back in it recovers. When I hit a bump the fuel gauge goes down....next bump gauge comes back. Also "check engine" light does the same.
Cleaned battery terminals, checked all grounds I could see, shook and pulled on all wiring to recreate issue, replaced cam shaft position sensor, went to Auto Zone for a scan....scan says po138 which they say is an O2 sensor. Don't think that is the problem. Is it the problem?...two sensors are involved upstream and downstream...which one? Help!!!

the rancher is offline   Quote Quick Reply
Old 08-25-2012, 09:43 PM   #2
Newb
 
enforcer88's Avatar
 
Join Date: Aug 2012
Posts: 4
Check all your positive leads also. Distribution box, starter and alternator. Might check to see if any fuses are loose or relays. Gonna throw this out there too....neutral safety switch?

enforcer88 is offline   Quote Quick Reply
Old 08-25-2012, 10:22 PM   #3
Jeeper
 
Blind Dog's Avatar
 
Join Date: Jul 2012
Location: Des Moines, Iowa
Posts: 591
Sounds to me like the ground strap from the engine to the chassis is going bad. Backing up would twist the engine against the mounts in the opposite direction it usually torques in forward driving, and that could be a clue here. Just a guess.
__________________
In God we trust.
All others bring data.

----------------------
'02 Sport, soft top, 6 cylinder
5 speed manual, 4" lift, 33.5" tires
~144K miles
Blind Dog is offline   Quote Quick Reply
Old 08-26-2012, 07:09 AM   #4
Newb
 
Join Date: Nov 2011
Posts: 3
Enforcer88 and Blind Dog thank you vary much I will be checking these things out today. I hope I will find. I will keep you posted.
the rancher is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 04:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC