Power steering sensor - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-07-2013, 05:26 AM   #1
Jeeper
 
joshrylant's Avatar
 
Join Date: Mar 2010
Posts: 39
Power steering sensor

Has anyone else had a problem with the plug on their power steering pump pressure sensor go out? Mine is leaking, i have called the local dealerships and no one can seem to find the part # for that plug. I'm losing quite a bit of fluid. What have you done to fix the problem? I currently pulled the sensor itself and plugge the line, but i'd rather just replace the plug and kill the check engine light. Any advice?

joshrylant is offline   Quote
Old 09-07-2013, 06:49 AM   #2
Jeeper
 
harryhood's Avatar
 
Join Date: Jul 2013
Posts: 385
Need to know the year of your TJ. But if you go to RockAuto Parts Catalog and look it up there you'll find it.

harryhood is offline   Quote
Old 09-07-2013, 07:51 AM   #3
Jeeper
 
joshrylant's Avatar
 
Join Date: Mar 2010
Posts: 39
Its a 99...
joshrylant is offline   Quote
Old 09-07-2013, 06:49 PM   #4
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,495
It may not be listed in some catalogs but the dealer part #, I think, is 56027906AB. It is in the switch section of the dealer catalog. I find it in the link below on page 157 of 594 section 008-805 (’99) item #24. That Morris site also has online FSMs. With that # you can search other sources.

http://www.jeep4x4center.com/jeep-pa...ts-Catalog.pdf
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is online now   Quote
Old 09-07-2013, 08:14 PM   #5
Jeeper
 
harryhood's Avatar
 
Join Date: Jul 2013
Posts: 385
harryhood is offline   Quote
Old 09-07-2013, 08:36 PM   #6
Jeeper
 
R u s s's Avatar
 
Join Date: Jul 2013
Location: Snohomish County
Posts: 358
Images: 2
Had mine go out and it filled my ecm up with oil. It pushed the oil up the wire and wicked in at the ecm plug.
I was able to get one from autozone it was under power steering pressure switch.
R u s s is offline   Quote
Old 09-14-2013, 05:29 AM   #7
Jeeper
 
joshrylant's Avatar
 
Join Date: Mar 2010
Posts: 39
So does the sensor itself hold the fluid? If i unplug the harness and drive, it shouldn't leak at all, correct?
joshrylant is offline   Quote
Old 09-14-2013, 10:15 AM   #8
Jeeper
 
R u s s's Avatar
 
Join Date: Jul 2013
Location: Snohomish County
Posts: 358
Images: 2
Should not leak at all. The seals on mine were so good that it never got the outside of the plug wet with oil. But when I took it off it was full of oil.
R u s s is offline   Quote
Old 09-28-2013, 05:54 AM   #9
Jeeper
 
joshrylant's Avatar
 
Join Date: Mar 2010
Posts: 39
Installed new PSS. No more leaks!
joshrylant is offline   Quote
Old 09-28-2013, 09:43 AM   #10
Jeeper
 
R u s s's Avatar
 
Join Date: Jul 2013
Location: Snohomish County
Posts: 358
Images: 2
Sweet

R u s s is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC