Question about startup - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-09-2012, 11:39 AM   #1
Jeeper
 
3025826's Avatar
 
Join Date: Mar 2010
Location: Kansas
Posts: 180
Images: 1
Question about startup

Hey everybody thinking my my fuel pressure regulator is out, but maybe fuel pump, or injectors. My 4.0 has always seemingly started up kind of slow but lately it's gotten worse. I let it cycle with the key on for about 5 seconds and it's still not great. I put a new diehard platitunum battery in a month ago which definitely gives the starter more kick but lately seemed to stop helping much. It idles higher than usual sometimes as well, not sure if it's related, and the gas gauge is sometimes off by a decent amount. Any ideas?

3025826 is offline   Quote
Old 04-09-2012, 11:41 AM   #2
Jeeper
 
3025826's Avatar
 
Join Date: Mar 2010
Location: Kansas
Posts: 180
Images: 1
I'm just trying to get it to start easy and run smooth
3025826 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:11 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC