rapid clicking when starting - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-21-2011, 05:25 PM   #1
i am fluent in kryptonian

WF Supporting Member
 
thetoadLJ's Avatar
 
Join Date: Jan 2010
Location: So Cal
Posts: 478
rapid clicking when starting

when i try to start my jeep i get a rapid click sound from the starter im guessing. ive had my battery tested and its good, ive replaced my terminal clamps and checked the water level in my battery. ive also had my starter and alternator tested and all came back ok.

any suggestions as to why it wont start?

thanks in advance ^^

__________________
LJ I6 4.0l, Rubicon Express 4.5" lift, 32" BFG A/T tires, steel ProComp wheels, Body Armor rear bumper, Hanson rocksliders, Skidrow skid plate, KC Daylighters 6" 130w long range lights, Smittybuilt XRC-8 winch, Cobra mini CB radio
thetoadLJ is offline   Quote Quick Reply
Old 02-21-2011, 05:27 PM   #2
Jeeper

WF Supporting Member
 
derekshep's Avatar
 
Join Date: Feb 2010
Location: glasgow, ky
Posts: 454
the starter?

derekshep is offline   Quote Quick Reply
Old 02-21-2011, 05:27 PM   #3
Jeeper

WF Supporting Member
 
derekshep's Avatar
 
Join Date: Feb 2010
Location: glasgow, ky
Posts: 454
i have the same problem my starter is going out and does it sometime but still test ok
derekshep is offline   Quote Quick Reply
Old 02-21-2011, 05:35 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,170
Images: 2
99 times out of 100, the starter is not the cause of that problem. More likely the battery has a bad, loose, or corroded connection at one or both of its posts. Or the battery is simply too weak to fully engage the starter. Start by wire brushing both battery connectors and getting them tight when you reinstall them back onto the battery.

If that doesn't do it, charge the battery overnight with a bench charger. And if that doesnt fix it, have the battery load tested at your local auto parts store as the battery may be nearly dead and in need of replacement.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-21-2011, 05:43 PM   #5
Jeeper

WF Supporting Member
 
derekshep's Avatar
 
Join Date: Feb 2010
Location: glasgow, ky
Posts: 454
i read wrong i thought it was making noise after started, jerrys right
derekshep is offline   Quote Quick Reply
Old 02-21-2011, 06:34 PM   #6
i am fluent in kryptonian

WF Supporting Member
 
thetoadLJ's Avatar
 
Join Date: Jan 2010
Location: So Cal
Posts: 478
i already cleaned my terminals twice each with terminal cleaner and a wire brush tool and that didnt change anything. im thinking the connectors might not have a tight connection. ill post pics up as soon as i can and maybe yall can tell if its tight enough.
__________________
LJ I6 4.0l, Rubicon Express 4.5" lift, 32" BFG A/T tires, steel ProComp wheels, Body Armor rear bumper, Hanson rocksliders, Skidrow skid plate, KC Daylighters 6" 130w long range lights, Smittybuilt XRC-8 winch, Cobra mini CB radio
thetoadLJ is offline   Quote Quick Reply
Old 02-21-2011, 06:52 PM   #7
i am fluent in kryptonian

WF Supporting Member
 
thetoadLJ's Avatar
 
Join Date: Jan 2010
Location: So Cal
Posts: 478
Here are the pics
Attached Thumbnails
Click image for larger version

Name:	image-2748510057.jpg
Views:	36
Size:	82.3 KB
ID:	38846   Click image for larger version

Name:	image-160791588.jpg
Views:	31
Size:	76.6 KB
ID:	38847  

Click image for larger version

Name:	image-3033324091.jpg
Views:	34
Size:	81.9 KB
ID:	38848  
__________________
LJ I6 4.0l, Rubicon Express 4.5" lift, 32" BFG A/T tires, steel ProComp wheels, Body Armor rear bumper, Hanson rocksliders, Skidrow skid plate, KC Daylighters 6" 130w long range lights, Smittybuilt XRC-8 winch, Cobra mini CB radio
thetoadLJ is offline   Quote Quick Reply
Old 02-21-2011, 06:54 PM   #8
i am fluent in kryptonian

WF Supporting Member
 
thetoadLJ's Avatar
 
Join Date: Jan 2010
Location: So Cal
Posts: 478
my positive connector is the new one and thats how it looked after i cleaned and brushed it twice. should it look like that after 3 weeks of use?
__________________
LJ I6 4.0l, Rubicon Express 4.5" lift, 32" BFG A/T tires, steel ProComp wheels, Body Armor rear bumper, Hanson rocksliders, Skidrow skid plate, KC Daylighters 6" 130w long range lights, Smittybuilt XRC-8 winch, Cobra mini CB radio
thetoadLJ is offline   Quote Quick Reply
Old 02-21-2011, 07:07 PM   #9
Jeeper
 
pslamp32's Avatar
 
Join Date: Jan 2011
Location: Asheville, NC
Posts: 226
Images: 3
Have you hooked up a multimeter to test the battery? Probably needs a new one...
__________________
'More than any other time in history, mankind faces a crossroads. One path leads to despair and utter hopelessness. The other to total extinction.Let us pray we have the wisdom to choose correctly.' -Woody Allen
pslamp32 is offline   Quote Quick Reply
Old 02-23-2011, 07:45 AM   #10
i am fluent in kryptonian

WF Supporting Member
 
thetoadLJ's Avatar
 
Join Date: Jan 2010
Location: So Cal
Posts: 478
got a new battery from the mechanic at my work and it seems to have fixed the problem. thanks for all your help everyone!

anyone know how ac delco batteries rate against others? like the diehard platinum everyone loves or anythign else?

__________________
LJ I6 4.0l, Rubicon Express 4.5" lift, 32" BFG A/T tires, steel ProComp wheels, Body Armor rear bumper, Hanson rocksliders, Skidrow skid plate, KC Daylighters 6" 130w long range lights, Smittybuilt XRC-8 winch, Cobra mini CB radio
thetoadLJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough starting with carbs Kommy000 YJ Tech Forum 0 08-28-2010 06:46 PM
Trouble with stalling/difficult starting... CSmith1128 TJ Tech Forum 1 04-22-2010 10:57 PM
Strange clicking noise in drivetrain Ohio Patriot TJ Tech Forum 6 11-14-2009 03:07 PM
Clicking Front End? ChilliRed TJ Tech Forum 13 10-18-2006 10:08 PM
Clicking after wet interier Wr@ngler00 TJ Tech Forum 6 07-10-2006 02:24 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC