Rear windsheild wiper - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-17-2012, 11:11 AM   #1
Newb
 
justlaxn23's Avatar
 
Join Date: Feb 2012
Posts: 6
Rear windsheild wiper

I just put my hard top back on for winter and the windshield wiper and fluid doesn't work. The defroster work though. Anyone have any suggestions ?

justlaxn23 is offline   Quote
Old 10-17-2012, 01:36 PM   #2
Jeeper
 
commodore_dude's Avatar
 
Join Date: Feb 2011
Location: Alpharetta, GA
Posts: 520
If neither work, I'd think the place to start is the switch... the wiring going to the back of the top must be at least partially good if the defrost works.

commodore_dude is offline   Quote
Old 10-17-2012, 02:04 PM   #3
Jeeper
 
jefferyfghezzi's Avatar
 
Join Date: Jan 2011
Location: SANDUSKY OHIO
Posts: 640
Check the fuse behind the glove box #6 I believe. Defrost relay is#15. At least thats for a 2005.
jefferyfghezzi is offline   Quote
Old 10-17-2012, 06:12 PM   #4
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 2,293
Check fuse first as Jeffery had suggested before proceeding to next steps :Take out a volt meter and check power at the wiper to rule out a bad wiper. If no power, check at back of switch to rule out bad switch.
Wattapunk is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:36 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC