RPM problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-04-2011, 05:04 PM   #1
Newb
 
Join Date: Aug 2011
Posts: 2
Exclamation RPM problem

my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.

we.go.ride.808 is offline   Quote Quick Reply
Old 08-04-2011, 06:29 PM   #2
Jeeper
 
necromancer_tat's Avatar
 
Join Date: Feb 2011
Location: Norfolk Virginia
Posts: 1,793
Quote:
Originally Posted by we.go.ride.808 View Post
my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.

Any check engine lights? Are you running the ac when this happens? How well does it run when you aren't stopped?

necromancer_tat is offline   Quote Quick Reply
Old 08-04-2011, 10:18 PM   #3
Jeeper
 
NHWRANGLER's Avatar
 
Join Date: Jul 2011
Posts: 169
new throttle return springs.
__________________
its a jeep thing. You wouldn't understand.

When in doubt, ask Jerry.
NHWRANGLER is offline   Quote Quick Reply
Old 08-05-2011, 08:40 PM   #4
Newb
 
Join Date: Aug 2011
Posts: 2
Quote:
Originally Posted by necromancer_tat View Post
Any check engine lights? Are you running the ac when this happens? How well does it run when you aren't stopped?
the check engine light comes on quite often. but i held the dash button and turned the car on, (so it would give me the code to whats wrong) and it says "no faults" each time. then i tighten my gas cap and it goes away soon after. and no, i never run a/c in my car. and it runs fine, the only times i have problems is when im stopped.
we.go.ride.808 is offline   Quote Quick Reply
Old 08-05-2011, 08:46 PM   #5
Jeeper
 
C.L.'s Avatar
 
Join Date: Mar 2011
Location: North NJ
Posts: 2,020
With an '04 you don't hold the trip reset. Just turn the ignition on and off 3 times in 6 seconds (ending with on) without starting it. The codes will display in the odometer area. My idle was acting up at stoplights just before the TPS failed. Replacing it cleared the codes and smoothed out the idle.

I've also heard people say cleaning their IAC cured rough idle.
C.L. is offline   Quote Quick Reply
Old 08-06-2011, 01:11 AM   #6
Jeeper
 
MikeMTJ's Avatar
 
Join Date: Nov 2009
Location: If only I knew....
Posts: 2,113
Send a message via AIM to MikeMTJ
Quote:
Originally Posted by C.L.
With an '04 you don't hold the trip reset. Just turn the ignition on and off 3 times in 6 seconds (ending with on) without starting it. The codes will display in the odometer area. My idle was acting up at stoplights just before the TPS failed. Replacing it cleared the codes and smoothed out the idle.

I've also heard people say cleaning their IAC cured rough idle.
x2
MikeMTJ is offline   Quote Quick Reply
Old 08-06-2011, 01:14 AM   #7
Jeeper
 
MikeMTJ's Avatar
 
Join Date: Nov 2009
Location: If only I knew....
Posts: 2,113
Send a message via AIM to MikeMTJ
Quote:
Originally Posted by we.go.ride.808
my 04' has been having problems with the RPMs. when in neutral the rpms sway between 400-750rpms, like constantly moving up and down. a few times it got so bad it has stalled while sitting at stop lights. i am not the most knowledgeable person about engines, if you have any ideas on what the problem is, please let me know. thanks.
Read through this:
http://www.jeepforum.com/forum/f9/lo...topped-961477/

MikeMTJ is offline   Quote Quick Reply
Reply

Tags
2004 , neutral , rpm , stalling , tjs

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! I am pulling my hair out with my jeep's engine cut-off problem HRDRCKN YJ Tech Forum 7 09-08-2011 12:47 PM
Grand Cherokee, starting problem after getting fuel injector serviced SusanH YJ General Discussion Forum 5 02-26-2011 01:04 PM
Intermittent Starting Problem airexec2 TJ Tech Forum 0 12-06-2010 12:49 PM
Intermittent engine bucking problem 98TJsport TJ Tech Forum 0 11-08-2010 03:42 PM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 01:03 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:47 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC