runs for 3 sec and dies - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-26-2012, 07:04 PM   #1
Jeeper
 
Join Date: Dec 2010
Posts: 16
runs for 3 sec and dies

99 4.0 in 89 wrangler. You can start it and it will run for 3 secs and then die. Sounds like it is running out of fuel. Inline fuel pump, 55 lbs. can squirt fuel in throttle body and keep it running. fuel pump works like it should. replaced iac and temp, still no help. Why is this happening.

gregb is offline   Quote Quick Reply
Old 02-26-2012, 07:07 PM   #2
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,827
Check your key. Sounds like the battery Is dead.

__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 02-26-2012, 07:07 PM   #3
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,465
Images: 2
Sounds like the ECM may not be happy with the output signal from either the crankshaft position sensor or camshaft position sensor. When that happens, the ECM disables the fuel pump.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-26-2012, 07:12 PM   #4
Jeeper
 
Join Date: Dec 2010
Posts: 16
Fuel pump stays on for a few secs after the motor dies.
gregb is offline   Quote Quick Reply
Old 02-26-2012, 07:14 PM   #5
Jeeper
 
UnlimitedLJ04's Avatar
 
Join Date: Aug 2010
Posts: 7,244
any codes thrown in the ECM? check the OBDII port.
UnlimitedLJ04 is offline   Quote Quick Reply
Old 02-26-2012, 07:16 PM   #6
Jeeper
 
Join Date: Dec 2010
Posts: 16
I just installed this motor. It was running fine before. Don't have the data link hooked up yet.
gregb is offline   Quote Quick Reply
Old 02-26-2012, 07:16 PM   #7
Jeeper
 
Join Date: Oct 2011
Posts: 1,527
Quote:
Originally Posted by UnlimitedLJ04 View Post
any codes thrown in the ECM? check the OBDII port.
OBDII in an '89 model?
tangofox007 is offline   Quote Quick Reply
Old 02-26-2012, 07:18 PM   #8
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,465
Images: 2
Quote:
Originally Posted by gregb View Post
Fuel pump stays on for a few secs after the motor dies.
I should have included that if the ECM isn't happy with either of those two sensors, it shuts the ASD (Auto Shutdown) relay off which shuts the ignition off. The fuel pump probably has to time out.

I'd see if the ASD relay is shutting off when the engine dies.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-26-2012, 07:34 PM   #9
Jeeper
 
Join Date: Dec 2010
Posts: 16
If it shuts down the asd relay why can I keep it running with squirting fuel in throttle body. Will check asd relay in am.
gregb is offline   Quote Quick Reply
Old 02-26-2012, 07:53 PM   #10
Jeeper
 
hardcoretj's Avatar
 
Join Date: Dec 2011
Posts: 139
Sounds like you triggered an anti theft system .
hardcoretj is offline   Quote Quick Reply
Old 02-26-2012, 08:13 PM   #11
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,465
Images: 2
Quote:
Originally Posted by gregb View Post
If it shuts down the asd relay why can I keep it running with squirting fuel in throttle body.
Oh yeah, that wouldn't happen.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-26-2012, 08:15 PM   #12
Jeeper
 
locked's Avatar
 
Join Date: Dec 2011
Posts: 600
Images: 5
Is this engine running smoothly at idle for the duration of it running?
__________________
-ALL AMERICAN-
Powder-Coating
WARD, AR
locked is offline   Quote Quick Reply
Old 02-26-2012, 08:43 PM   #13
Jeeper
 
UnlimitedLJ04's Avatar
 
Join Date: Aug 2010
Posts: 7,244
Quote:
Originally Posted by tangofox007 View Post
OBDII in an '89 model?
yup, since he's running a 1999 motor with a 1999 ECM. he's gotta be able to pull the codes somehow....the data link would give insight.
UnlimitedLJ04 is offline   Quote Quick Reply
Old 02-26-2012, 09:24 PM   #14
Jeeper
 
Join Date: Dec 2010
Posts: 16
Motor runs real smooth till it shuts down then you hear gasping for fuel at throttle body. It had a anti theft on jeep. Is it in the pcm?
gregb is offline   Quote Quick Reply
Old 02-26-2012, 09:26 PM   #15
Jeeper
 
Join Date: Dec 2010
Posts: 16
I have pinouts but didn't see anything about antitheft.
gregb is offline   Quote Quick Reply
Old 02-27-2012, 04:21 AM   #16
Jeeper
 
hardcoretj's Avatar
 
Join Date: Dec 2011
Posts: 139
Quote:
Originally Posted by gregb
I have pinouts but didn't see anything about antitheft.
Anti-theft is in the ECM. I had to have it flashed out when I did the v-8 swap in mine. www.autocomputerexchange.com. Cost $125 .
hardcoretj is offline   Quote Quick Reply
Old 02-27-2012, 07:30 AM   #17
Jeeper
 
Join Date: Dec 2010
Posts: 16
Thanks guys. Will try a few things today and get my data link hooked up. Will check back tonight. Thanks again.
gregb is offline   Quote Quick Reply
Old 02-27-2012, 06:05 PM   #18
Jeeper
 
Join Date: Dec 2010
Posts: 16
Did find out the injectors were shutting down when motor quit but ing was still on. Thats why I could keep it running with extra fuel. ASD relay has 12 volts all times one wire. When key is on it has 12volts to two other wires and 8 volts to the other one. Still haven't fixed yet.
gregb is offline   Quote Quick Reply
Old 02-27-2012, 07:46 PM   #19
Jeeper
 
hardcoretj's Avatar
 
Join Date: Dec 2011
Posts: 139
I'm telling you it is the anti theft.
hardcoretj is offline   Quote Quick Reply
Old 02-28-2012, 09:15 AM   #20
Sponsoring Vendor

WF Supporting Member
 
Black Magic Brakes's Avatar
 
Join Date: May 2011
Posts: 1,852
Quote:
Originally Posted by gregb View Post
Thanks guys. Will try a few things today and get my data link hooked up. Will check back tonight. Thanks again.
When it finally locks you completely out and won't even let the starter turn over, then you will know the SKIM has been activated and you'll have to have it reset. Also, look for a light on the dash that looks like a key with a circle and slash around it that it lit up.
__________________
I am Savvy, I am the brake Wizard.
http://blackmagicbrakes.com
Black Magic Brakes is offline   Quote Quick Reply
Old 02-28-2012, 09:02 PM   #21
Jeeper
 
Join Date: Dec 2010
Posts: 16
If you read the earler post I installed this 4.0 out of 99 to an 89 wrangler. You were right, anti theft was sutting down injectors after 3 secs. Chysler can't flash the pcm without the jeep. Well this jeep only has the fuel injection harness. I wired the 99 steering wheel up next to my jeep with the key. Got it running real nice. Going to take anti theft module and key out of steering wheel, tape it up and stuff it under dash of 89 till I can get another pcm. Thanks again for all your help. Couldn't have done it without you all. This is pretty darn good site. Thanks.
gregb is offline   Quote Quick Reply
Old 02-29-2012, 04:08 AM   #22
Jeeper
 
hardcoretj's Avatar
 
Join Date: Dec 2011
Posts: 139
www.autocomputerexchange.com can make the security function go away ,if you cant find another ECU.

hardcoretj is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
looking for campground brightsidememe California Jeep Forum 39 03-02-2012 01:25 AM
Best Manifold for 97 TJ terminator012 TJ General Discussion Forum 10 02-28-2012 03:23 PM
Best lift for my needs... SolarStar JK General Discussion Forum 10 02-26-2012 07:51 PM
kc hilites and rain?? kbryant88 JK General Discussion Forum 7 02-26-2012 06:39 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC