Runs like cramp!! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-22-2011, 03:09 PM   #1
Newb
 
Join Date: Jun 2011
Posts: 6
Runs like cramp!!

we have a 99 jeep wrangler 2.5L.Had a rebuilt engine just put in.Now missing bad,backfireing and has no power. this is what has been done so far. 1 timed 2 new plugs 3 new injectors 4 got rid of cat. convertor.any help be great .

larr15442 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SW Washington & NW Oregon Group n2jeepn Oregon Jeep Forum 2154 05-31-2015 12:26 AM
SW Washington Runs, Events, Meet-in-Greets n2jeepn Washington Jeep Forum 139 05-14-2012 10:33 AM
Howell Runs Too Lean. Help! Fredzo YJ Tech Forum 1 06-25-2011 12:43 PM
yj runs rough macks-94yj YJ Tech Forum 2 03-08-2011 05:09 PM
jeep starts and runs great then after warming up acts like it is out if time? woodfordjay YJ Tech Forum 8 02-22-2011 05:58 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:17 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC