Speedometer Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-13-2013, 05:41 PM   #1
Jeeper
 
RAGMAN's Avatar
 
Join Date: Jul 2009
Location: Northern Kentucky
Posts: 338
Send a message via Skype™ to RAGMAN
Speedometer Help

Hi

This morning I was going change my transfer case fluid but did not have the correct tool. So Instead I just checked it by removing the speedo gear to feel the level and see the color. When I put the gear back in and drove it I noticed the speedometer was not working and it was before. So I removed it and reseated it and drove around the block but it still does not work, I removed it and cleaned and reseated again still no change . So I replaced the speed sensor attached to it and still no luck. What did I do? Any ideas on what to do next or how to fix would be appreciated

It's a 2006 Wrangler X 6sp NP231


Thanks in advance

__________________

2006 Jeep Wrangler X
2.5'' Rough Country Lift
15x8 Rebel Racing (Blackout Rims)
31x10.5 Toyo Open Country AT
"I Live, I Ride, I AM.... JEEP!"
"It's not that I'm Lazy, it's that i just dont care!"
RAGMAN is offline   Quote Quick Reply
Old 07-13-2013, 05:58 PM   #2
Jeeper
 
wwch99tj's Avatar
 
Join Date: Mar 2011
Location: Felton Delaware
Posts: 4,786
You have to make sure the housing is clocked to the correct position for the #tooth gear you have.

http://www.4x4xplor.com/speedo.html

wwch99tj is offline   Quote Quick Reply
Old 07-13-2013, 06:43 PM   #3
Jeeper
 
RAGMAN's Avatar
 
Join Date: Jul 2009
Location: Northern Kentucky
Posts: 338
Send a message via Skype™ to RAGMAN
its in the same position i think problem is that with the metal clip that holds it in shown in the pic will only fit the grooves that were set as default when built i cannot adjust that cause the clip wont set in the groves or only one side fits
__________________

2006 Jeep Wrangler X
2.5'' Rough Country Lift
15x8 Rebel Racing (Blackout Rims)
31x10.5 Toyo Open Country AT
"I Live, I Ride, I AM.... JEEP!"
"It's not that I'm Lazy, it's that i just dont care!"
RAGMAN is offline   Quote Quick Reply
Old 07-13-2013, 06:45 PM   #4
Jeeper
 
RAGMAN's Avatar
 
Join Date: Jul 2009
Location: Northern Kentucky
Posts: 338
Send a message via Skype™ to RAGMAN
wouldn't it still work and just be way off? it doesnt show any speed at all
__________________

2006 Jeep Wrangler X
2.5'' Rough Country Lift
15x8 Rebel Racing (Blackout Rims)
31x10.5 Toyo Open Country AT
"I Live, I Ride, I AM.... JEEP!"
"It's not that I'm Lazy, it's that i just dont care!"
RAGMAN is offline   Quote Quick Reply
Old 07-13-2013, 08:13 PM   #5
Yipeee Kay Ayyy

WF Supporting Member
 
Wesboy's Avatar
 
Join Date: Feb 2010
Posts: 2,036
Quote:
Originally Posted by RAGMAN View Post
wouldn't it still work and just be way off? it doesnt show any speed at all
Mine didn't.
There's only 4 positions the speedo housing can be re-installed.
Mine didn't work at all in the 3 incorrect positions.
__________________
97 TJ Sport 4.0L Auto RHD
http://www.wranglerforum.com/profile.php?do=updatesignature#sigpic
Wesboy is offline   Quote Quick Reply
Old 07-13-2013, 09:44 PM   #6
Jeeper
 
RAGMAN's Avatar
 
Join Date: Jul 2009
Location: Northern Kentucky
Posts: 338
Send a message via Skype™ to RAGMAN
hmm ill try to rotate it and make sure its in the right spot thanks
__________________

2006 Jeep Wrangler X
2.5'' Rough Country Lift
15x8 Rebel Racing (Blackout Rims)
31x10.5 Toyo Open Country AT
"I Live, I Ride, I AM.... JEEP!"
"It's not that I'm Lazy, it's that i just dont care!"
RAGMAN is offline   Quote Quick Reply
Old 07-14-2013, 05:48 PM   #7
Jeeper
 
RAGMAN's Avatar
 
Join Date: Jul 2009
Location: Northern Kentucky
Posts: 338
Send a message via Skype™ to RAGMAN
that worked thanks i had it in the wrong numbers

__________________

2006 Jeep Wrangler X
2.5'' Rough Country Lift
15x8 Rebel Racing (Blackout Rims)
31x10.5 Toyo Open Country AT
"I Live, I Ride, I AM.... JEEP!"
"It's not that I'm Lazy, it's that i just dont care!"
RAGMAN is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 08:36 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC