Stalling engine turns off - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-21-2010, 07:11 PM   #1
Newb
 
Join Date: Dec 2010
Posts: 5
Cool Stalling engine turns off

I have a 99 wrangler 4.0 automatic. Having problems stalling. In the mornings when placing in reverse, backing up, coming to a stop then placing trans in drive, the motor stalls and dies. It will restart no problems, then will drive to stop sign, will stop, the engine stalls and dies, but will restart no problems. Noticed that trans wants to shift from 1st to 2nd,2nd to 1st with a mind of its own. The stalling happens mostly when cold. once in awhile it will stall when hot when stopped at stop sign. HELP!

romel is offline   Quote Quick Reply
Old 12-21-2010, 07:27 PM   #2
Supporting Member

WF Supporting Member
 
Always Stuck's Avatar
 
Join Date: Sep 2010
Location: South of Boston Ma
Posts: 519
If you start it and put it in gear with your foot on the brake but don't move does it stall or does it idle correctly.

__________________
-------------------------------------------
Where did all my money go O ya I bought a Jeep....

My 94 Buildhttp://www.wranglerforum.com/f118/le...gin-68903.html
Always Stuck is offline   Quote Quick Reply
Old 12-21-2010, 08:45 PM   #3
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,599
Would definitely check engine RPMs at idle. around 800-1100 RPMs optimal IMHO. Beyond that, anything else change recently.....new Transmission fluid??? new anything else????
bc3_Jeep is offline   Quote Quick Reply
Old 12-21-2010, 09:05 PM   #4
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
start with cleaning throttle body and idle air control.
jasonwrangler is offline   Quote Quick Reply
Old 12-21-2010, 09:14 PM   #5
Newb
 
Join Date: Dec 2010
Posts: 5
When I first start the jeep I can place my foot on the brake and place into gear, NO STALL. I have taken the thottle body off and complete clean, I also replaced the idle air control, still no change. I was told that it could be the trans torque converter? has anyone heard of this?
romel is offline   Quote Quick Reply
Old 12-21-2010, 10:09 PM   #6
Newb
 
Join Date: Dec 2010
Posts: 5
About a week ago I did add Lucus to the trans, but no change. Do you think that if I change the trans fluid it might make a difference?
romel is offline   Quote Quick Reply
Old 12-21-2010, 11:33 PM   #7
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
when stalling can you feel power going to the wheels?
jasonwrangler is offline   Quote Quick Reply
Old 12-22-2010, 09:49 AM   #8
Newb
 
Join Date: Dec 2010
Posts: 5
Yes, As soon as I place it into drive I feel a quick jerk and then stalls.
romel is offline   Quote Quick Reply
Old 12-22-2010, 11:10 AM   #9
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
It's possible it's the converter, but it's about as likely as a meteorite hitting you.

Usually when the converter does that it's a sudden "bang" - then the engine stops abruptly. Not just a slow spin down.

Sounds to me more like a vacuum leak somewhere, like the brake booster diaphragm is tearing.
Keep track - when it stalls I'd bet you are touching the brake at the same time.

It's more likely when cold too.

If you don't notice an association with stalling and braking, then suspect a major vacuum leak like intake manifold to head. Spray a burnable carb cleaner at the junctions looking for an RPM change.

Let us know please.
rrich is offline   Quote Quick Reply
Old 12-22-2010, 05:17 PM   #10
Newb
 
Join Date: Dec 2010
Posts: 5
I will try the brake booster. I did the spray all around the intake and exhaust, hose's and you name it, I also thought maybe a vacume leak. I have not checked the booster. Thanks!
romel is offline   Quote Quick Reply
Old 12-22-2010, 05:52 PM   #11
Jeeper
 
Indy's Avatar
 
Join Date: Jun 2009
Location: Newark, CA (Bay Area) .. PM me for wheeling
Posts: 550
Have you cleaned your IAC yet? Try that too

__________________
98 TJ 4.7 Stroker!!! Unichip tuner, HPD30/D44, 4.56, Detroit Locker in rear axle, 3.25RC SL, 1.25BL, 1MML, 35x12.50x15, Cager Softs 15x8, XRC10 winch, Rancho 9000XL shocks with wireless remote
Indy is offline   Quote Quick Reply
Reply

Tags
but no change.

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light tbowden91 YJ Tech Forum 28 03-07-2014 10:20 PM
Engine problems... please help robbyr YJ Tech Forum 8 01-31-2011 09:18 AM
Engine problems... please help robbyr YJ Tech Forum 3 12-09-2010 10:26 PM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 10:58 AM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-07-2009 11:14 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:42 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC