starting issue, need help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-02-2012, 11:59 AM   #1
Jeeper
 
arcountryboy's Avatar
 
Join Date: Apr 2011
Location: England, AR
Posts: 849
starting issue, need help

I'm a old school SBC guy, this new stuff sucks. I have a 98 TJ 2.5 liter 5 speed. Been running fine until I left for lunch today. Started up and died instantly. Turned over a few times and nothing. I gave it a little gas and it fired right up, idled down real low, then came right back up to about 700 rpms. Runs smooth after that. Every single time you shut it off, you either have to give it gas to start it, or turn it over about 10 times. Fuel pump kicks on instantly, fuel rail when turned off for an hour still squirts gas out about 4 inches, when running all the way to the fender almost. Though it might be the check valve bleeding back, but if you kill it and start it back less than 3 seconds later, same issue. Any idea's? Maybe the throttle position sensor?

Battery tested good under load, battery cables and ends are tight, clean, and less than 1 month old.

__________________
Arkansas Crawlers
BlueRibbon Coalition


arcountryboy is offline   Quote
Old 02-02-2012, 12:15 PM   #2
Jeeper
 
BadMojo's Avatar
 
Join Date: Dec 2011
Location: Big Sandy Texas
Posts: 299
Yeah, being as you are seeing fuel pressure on the rail after it sits for a good while I'd lean towards either TPS or IAC. Usually an easy way to check to see if the IAC is bad, if you have A/C, at idle kick the A/C on, if the engine RPM drops then the IAC is probably bad. If the idle stays the same or drops for a split second then recovers to normal speed then possibly the TPS. Of course there are a lot of other things that can cause your symptoms, but those are where I'd start looking.

BadMojo is offline   Quote
Old 02-02-2012, 04:56 PM   #3
Jeeper
 
sig25's Avatar
 
Join Date: Jan 2012
Location: North of Tampa
Posts: 15
Def sounds like an Idle Air Control Valve issue (IAC). The IAC is what allows air into the engine to keep it running when the throttle plate is closed. The IAC meters the amount of air entering the engine. These valves do go bad but they can usually be removed & cleaned with carb cleaner as a temp fix.
sig25 is offline   Quote
Old 02-02-2012, 06:47 PM   #4
Jeeper
 
arcountryboy's Avatar
 
Join Date: Apr 2011
Location: England, AR
Posts: 849
Would it still be the IAC even if it idles fine after firing?
__________________
Arkansas Crawlers
BlueRibbon Coalition


arcountryboy is offline   Quote
Old 02-03-2012, 01:35 AM   #5
Jeeper
 
BadMojo's Avatar
 
Join Date: Dec 2011
Location: Big Sandy Texas
Posts: 299
Yeah, it depends on the position of the IAC pintle when it failed, being as they really only affect things at start up cold and when the engine load changes, as in turning on the AC compressor, they usually fail and stick in a position where it'll run fine once started and warmed a few seconds. I still lean towards the IAC.
BadMojo is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 11:00 AM
1990 Starting issue davelyn1991 YJ Tech Forum 9 08-09-2011 09:19 PM
starting/idloling issue (Pictures and Video) Vermonter YJ Tech Forum 2 07-28-2011 04:42 PM
YJ starting issue aness2323 General Jeep Discussion 1 11-25-2009 03:26 PM
Rough Idle and Starting Issue crashnburn54 TJ Tech Forum 6 10-30-2009 09:11 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:34 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC