Strange headlight problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-09-2011, 06:07 PM   #1
Jeeper
 
Join Date: Jul 2011
Location: Baltimore, Maryland
Posts: 22
Strange headlight problem

Hello everyone im having a strange headlight problem it seems that when i pull of the switch to turn the lights on the light wont turn on just the running lights but if i push it n a little bit the the lights will work normally low and high beam. When they dont work the only thing that works is the high beam flasher.

Does anyone know what could be wrong. My vehicle is a 97' TJ

Thanks,
Matt

Baltimore is offline   Quote
Old 08-09-2011, 06:10 PM   #2
Jeeper
 
RockyWrangler98's Avatar
 
Join Date: Jan 2011
Location: Tennessee
Posts: 8,127
Quote:
Originally Posted by Baltimore
Hello everyone im having a strange headlight problem it seems that when i pull of the switch to turn the lights on the light wont turn on just the running lights but if i push it n a little bit the the lights will work normally low and high beam. When they dont work the only thing that works is the high beam flasher.

Does anyone know what could be wrong. My vehicle is a 97' TJ

Thanks,
Matt
New switch time...

__________________
"Why do you drive something like that?" ...To which I reply: "To make people like you ask questions like that."
RockyWrangler98 is offline   Quote
Old 08-09-2011, 07:03 PM   #3
Jeeper
 
Join Date: Jul 2011
Location: Baltimore, Maryland
Posts: 22
Ok ill ebay it up.
Baltimore is offline   Quote
Old 08-09-2011, 07:52 PM   #4
Yipeee Kay Ayyy

WF Supporting Member
 
Wesboy's Avatar
 
Join Date: Feb 2010
Posts: 2,199
Had a similar thing happen with my '97.
Lights only came on when switch was halfway out- kinda not engaged properly.
Ended up being the fuse, you may want to check that first.
Wesboy is offline   Quote
Old 08-09-2011, 08:49 PM   #5
Jeeper
 
Join Date: Jul 2011
Location: Baltimore, Maryland
Posts: 22
Which fuse would that be
Baltimore is offline   Quote
Old 09-17-2011, 08:51 AM   #6
Newb
 
Join Date: Nov 2006
Location: New Jersey
Posts: 14
Images: 4
Hi Everybody,
Seems like the light switch could be my problem, sometimes the factory off road lights work, sometimes they don't, now it seems like the high beems are stuck on, cannot change back to low beams. Any ideas on what to check or how to replace the switch?
Thanks

WranglerX3 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight & Flasher Problem morriswa TJ General Discussion Forum 1 04-28-2011 07:40 PM
Strange Problem woweternal TJ Tech Forum 1 05-13-2010 04:54 AM
headlight help! JCallaway TJ Tech Forum 2 04-09-2010 02:52 AM
Headlight problem lclaymore TJ Tech Forum 3 03-29-2010 08:42 AM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 01:03 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:46 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC