Strange turn single behavior - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-23-2012, 04:13 PM   #1
Jeeper
 
camtron3712's Avatar
 
Join Date: Apr 2011
Location: Louisiana
Posts: 377
Unhappy Strange turn single behavior

Alright, My drivers side rear turn signal been doing the same thing as if the light was out.. (blinks fast) i figured it was a short inside the light somewhere. all of the other lights are working. i ordered a new rear light assembly and just got it installed. now it works fine.

But here is the catch. it all works fine until i turn the head lights on. after that, When i turn the signal on, it starts blinking fast light it would if one of the lights were out, but yet they are all working. the brake lights work and the reverse lights work..

I think the problem is the switch. Am i wrong? What does wrangler forum think?

Thanks in advanced

camtron3712 is offline   Quote
Reply

Tags
turn signal

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:50 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC