switches are always on? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-09-2014, 08:51 PM   #1
Jeeper
 
Join Date: Sep 2013
Posts: 28
switches are always on?

Guys,

I just installed a couple of kc fog lights and the lights on the switches won't shut off. Where did I go wrong in my wiring? I followed the directions very closely. I'm pretty confused right now. Thanks.

Bobcat22 is offline   Quote
Old 07-09-2014, 09:03 PM   #2
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 7,743
Images: 11
Don't know what switch you're using or how you wired it, but it sounds like you have the line and load wires reversed on the switch.

__________________
Dennis
Water Dog is offline   Quote
Old 07-09-2014, 09:18 PM   #3
Jeeper
 
Join Date: Sep 2013
Posts: 28
I used the switches that look like stock switches. Red for power, white for the relay, and black for the ground. The kc kit has green and white wires going to the switch. The red is connected to the green and the white is connected to the white.
Bobcat22 is offline   Quote
Old 07-09-2014, 09:40 PM   #4
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 7,743
Images: 11
Quote:
Originally Posted by Bobcat22 View Post
I used the switches that look like stock switches. Red for power, white for the relay, and black for the ground. The kc kit has green and white wires going to the switch. The red is connected to the green and the white is connected to the white.
Try reversing the red and white.....red to white, and white to green.
__________________
Dennis
Water Dog is offline   Quote
Old 07-09-2014, 10:40 PM   #5
Jeeper
 
Join Date: Sep 2013
Posts: 28
That's what it was. Crossed wires. I'm an idiot. Thanks.
Bobcat22 is offline   Quote
Old 07-09-2014, 11:37 PM   #6
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 7,743
Images: 11
Quote:
Originally Posted by Bobcat22 View Post
That's what it was. Crossed wires. I'm an idiot. Thanks.
Sometimes it just takes seeing it from a different perspective. Glad you got it figured out.

__________________
Dennis
Water Dog is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:55 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC