SYE install but speedometer not working - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-07-2013, 08:50 PM   #1
Jeeper
 
leebrewer3's Avatar
 
Join Date: May 2013
Posts: 17
SYE install but speedometer not working

I installed this SYE on my 97 TJ:

http://www.jeep4x4center.com/alloy-u...all-11400.html

I assumed my factory sensor and gear would work but the speedometer isn't working and it's tripping my check engine according to the code I pulled. Should I order a new sensor gear? I need to anyway to compensate for the 33 12.50 I am running. Any suggestions? If you look at the pic of the SYE you will notice the blue plastic speed gear on the shaft inside the housing. Could I have it on backwards? Lol...

Thanks for any input...

leebrewer3 is offline   Quote
Old 07-07-2013, 09:01 PM   #2
Jeeper
 
Jeep_guy3's Avatar
 
Join Date: Aug 2011
Location: Lincoln County, OR
Posts: 306
I don't think the blue speedo gear was directionally orientated. I had a similar problem when I installed my SYE. Make sure that you have the speedo sensor in all the way, mine wasn't all the way in the new tail piece, and wouldn't actually go in without a little bit of sanding on the very end, just make sure to sand it away from the hole and clean it off really well so you don't have any of the small plastic partials floating in your Tcase

__________________
My JEEP helped win a war, your HONDA cuts my grass!
Jeep_guy3 is offline   Quote
Old 07-07-2013, 09:12 PM   #3
Jeeper
 
leebrewer3's Avatar
 
Join Date: May 2013
Posts: 17
Quote:
Originally Posted by Jeep_guy3 View Post
I don't think the blue speedo gear was directionally orientated. I had a similar problem when I installed my SYE. Make sure that you have the speedo sensor in all the way, mine wasn't all the way in the new tail piece, and wouldn't actually go in without a little bit of sanding on the very end, just make sure to sand it away from the hole and clean it off really well so you don't have any of the small plastic partials floating in your Tcase
Do you think one off these gears will do the trick? I need to get one anyway to correct for my tire size..

http://www.jeep4x4center.com/jeep-sp...ears/index.htm
leebrewer3 is offline   Quote
Old 07-07-2013, 09:12 PM   #4
Jeeper
 
T2000J's Avatar
 
Join Date: Sep 2010
Location: PA
Posts: 897
Your speedo sensor needs spun a little one way or the other . The gears are not making contact . Would have been best when everything was apart to dry fit the speedo and mark it . There is only one way that the gears mesh together a little off and nothing works .
__________________


JEEP WRANGLER
T2000J is offline   Quote
Old 07-11-2013, 06:05 PM   #5
Jeeper
 
leebrewer3's Avatar
 
Join Date: May 2013
Posts: 17
I fixed my problem by orientating my sensor housing to the proper position based on how many teeth my speedometer gear has. This is the forum that helped:

http://www.4x4xplor.com/speedo.html

Thanks...
leebrewer3 is offline   Quote
Old 07-11-2013, 07:23 PM   #6
Jeeper
 
reissigree's Avatar
 
Join Date: Apr 2012
Posts: 517
I had the same problem. Take it back out and put it in at a different angle. I think I put it in and twisted it to the right as far as I could. Works now.
reissigree is offline   Quote
Old 11-18-2013, 06:38 AM   #7
Jeeper
 
4wheeljunky's Avatar
 
Join Date: Mar 2010
Posts: 25
I know this thread is a few months old. But I'm looking at doing the alloy USA kit. How do you like it so far? I can pick it up for less than 160 on amazon.

4wheeljunky is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:52 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC