throttle issue?????? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-11-2011, 09:18 PM   #1
Newb
 
Join Date: Aug 2011
Location: alabama
Posts: 1
throttle issue??????

hey guys,
Im a new member so be gentle. This is an awesome site, so I figured who better to ask then the jeep lovers. First off I will tell you what I have and what I've recently done to it. I have an 03 jeep wrangler se 4 cylinder 2.4L 5 speed manuel with 54,xxx miles. I have recently replaced the spark plugs and wires, changed the oil and oil filter, changed the air filter, and last replaced the throttle control sensor. Now for the issue that I hope you guys can help out with. It started out as just annoying check engine light. I ran the code and it said throttle position sensor was having issues. So after ignoring it for a few weeks, I finally went to the dealer and bought the oem tps. As soon as I installed it, everthing went to junk. Every stop sign I stop at the engine dies. When im accelerating, I'm being bucked around and jerked about. I then tried to put the old one back on, but it continued to do the voilent jerks. So I took it to a buddy who is a mechanic and he kept it for a few days. He ran a few test, replaced the idle sensor, and said it was fixed. He said that it wouldn't buck, but the check engine light would still be on. Well the first road I got on after I left the shop, it starting bucking again. So I took it back. He put the "Big computer up to it". long story short he thinks its a bad computer. When he hooked the computer up, it say its idling at 48%, but when he revs it it only changes by 1%. So I took it to a second mechanic, and he kept it for a few days. I thinks its a bad throttle body. Sorry guys for the 100 page book, but I figure the more information the better. What do you guys think, bad computer? bad throttle body? or something else?
thanks a ton!!!!!

laxkingin205 is offline   Quote Quick Reply
Old 08-12-2011, 07:13 AM   #2
Jeeper
 
James249G's Avatar
 
Join Date: Jul 2011
Location: Greater Atlanta Area
Posts: 103
I would start by checking your Idle Air Controller. If its an 03, there's a chance it could just use a good cleaning. That's the CHEAPEST possible answer. As for your computer, sometimes after replacing your TPS or IAC it takes a while for your ECU to "re-learn" and re-set itself. If that's not happening, it MAY be the problem.
Good luck, bro.

James249G is offline   Quote Quick Reply
Old 08-12-2011, 06:41 PM   #3
Jeeper
 
Indy's Avatar
 
Join Date: Jun 2009
Location: Bay Area
Posts: 554
Try resetting your computer. Leave the battery disconnected overnight to completely erase the memory. See if that helps.
__________________
98 TJ 4.7 Stroker!!! Unichip tuner, HPD30/D44, 4.56, Detroit Locker in rear axle, 3.25RC SL, 1.25BL, 1MML, 35x12.50x15, Cager Softs 15x8, XRC10 winch, Rancho 9000XL shocks with wireless remote
Indy is offline   Quote Quick Reply
Old 08-12-2011, 06:46 PM   #4
Jeeper
 
Join Date: Jul 2009
Location: NE Wyoming
Posts: 328
Welcome to the forum! Also welcome to the world of Jeeps! Can't help ya with your problem, but the resetting the computer can't hurt.
Wyominer is offline   Quote Quick Reply
Reply

Tags
idle problems , throttle , throttle body , throttle position sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 11:00 AM
Idle issue PadreC TJ Tech Forum 1 02-18-2011 04:05 PM
Power loss above 1/2 throttle, code 51 Roving.Richard YJ Tech Forum 2 02-12-2011 04:26 PM
New Jeeper. Fuel Issue? 2nd post South23 YJ Tech Forum 14 06-06-2010 11:10 AM
Throttle Body Issue??? bnajeep General Jeep Discussion 1 08-24-2009 12:56 PM



» Featured Product

All times are GMT -5. The time now is 03:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC