throttle issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-07-2012, 08:27 PM   #1
Jeeper
 
c1skout's Avatar
 
Join Date: Feb 2012
Posts: 50
throttle issues

2005 Wrangler x
My jeep "bucks" when I'm travelling at low speed and apply throttle....like when you're going through a parking lot. Sometimes it gets so bad I have to push the clutch in till it settles down. I've replaced the plugs and removed and cleaned the throttle body but that didn't help (but it did fix the erratic idle speed it had) Is this common behavior?

c1skout is offline   Quote Quick Reply
Old 09-07-2012, 09:03 PM   #2
Jeeper
 
SeVeReDiStOrTiOn's Avatar
 
Join Date: May 2012
Location: CA
Posts: 768
This might not be your problem but mine did the same thing when the rear driveshaft to diff u-joint went out. Are you getting any vibrations through the other gears? I think the driveshaft was binding up causing my jeep to buck.

SeVeReDiStOrTiOn is offline   Quote Quick Reply
Old 09-08-2012, 02:43 PM   #3
Jeeper
 
c1skout's Avatar
 
Join Date: Feb 2012
Posts: 50
No vibrations at all, this doesn't act like a u-joint, it's more like someone is tapping their foot on the gas pedal....on off on off until it seems like the engine is going to come out of the mounts.
c1skout is offline   Quote Quick Reply
Old 09-08-2012, 02:49 PM   #4
Jeeper
 
jeepdude2003's Avatar
 
Join Date: Dec 2011
Posts: 230
Is it cold where your at some time when its like 30s around here if i dont let my jeep warm up it shutters in first when i let out the clutch and my plugs are new and have a new tps
jeepdude2003 is offline   Quote Quick Reply
Old 09-08-2012, 05:06 PM   #5
Jeeper
 
c1skout's Avatar
 
Join Date: Feb 2012
Posts: 50
This is no shudder and it will do it after warmed up. I just had my wife ease the clutch in and out while I watched for play in the ujoints, motor and trans mounts and rear axle. Everything looks good, surprizingly good for 118,000+ miles.
c1skout is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 10:43 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC