tick...tick... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-24-2009, 01:00 AM   #1
Jeeper
 
Join Date: Apr 2009
Location: Salt Lake City
Posts: 95
tick...tick...

I have a sporadic and non-steady ticking noise coming from the fusebox area (behind the glove box) It ticks *waits a couple four seconds* tick *waits two seconds* tick *ten seconds* tick ... in other words it isn't steady and it isn't consistant, but it sounds like a relay or a switch. It only happens on my '03, not on my '00. Everything works and I haven't blown any fuses or had any malfunctions. Been doing that since I got it (year and 3 months) and I kinda tune it out. I'd rather fix it.

Anyone? Bueller?

Thanks
Chris

toplessartist is offline   Quote
Old 10-24-2009, 04:35 AM   #2
Jeeper
 
csamn2007's Avatar
 
Join Date: Aug 2009
Location: Peterson AFB CO
Posts: 1,911
Send a message via AIM to csamn2007
LMAO Bueller.

I would check for any loose wires and all grounds. No dimming lights when it ticks?

__________________
2000 Wrangler Sport
2 in Procomp SL 1 in BL
33 in Procomp MTs
csamn2007 is offline   Quote
Old 10-24-2009, 09:18 AM   #3
Jeeper
 
Join Date: Aug 2009
Posts: 68
I have the same thing. Only when the heat or defroster is on. I have checked everything. Don't know what it is.........??
wranglersteve is offline   Quote
Old 10-24-2009, 09:23 AM   #4
Jeeper
 
motokeen's Avatar
 
Join Date: Aug 2009
Location: k3
Posts: 927
Images: 1
Yep. Same here but its randomn. DOesn't do it to often.
motokeen is offline   Quote
Old 10-24-2009, 09:45 AM   #5
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
One of your relays is getting weak. The armature is supposed to be open (or closed) and is closing (or opening) for just a minute until the coil opens it back up.

It's probably for something you aren't using at the time that has power available.

When it's doing it, try touching the relays and you should be able to feel it snapping.

Ensure you have something more than 12v to 13.6v on the battery and if you do, replace that relay.
stevens243 is offline   Quote
Old 10-24-2009, 11:16 AM   #6
Newb
 
hishamsTJ's Avatar
 
Join Date: Jul 2009
Location: muscat oman
Posts: 8
Send a message via MSN to hishamsTJ
i think stevens243 is right also check if ur main belt is rolling well i hade same problem and i checked everything was fine i ve changed main belt and sound of tick tick disappeared
__________________
Don't Compare your jeep with anyother 4WD in this world. If you do so, you are insulting your JEEP
hishamsTJ is offline   Quote
Old 10-24-2009, 12:21 PM   #7
Jeeper
 
motokeen's Avatar
 
Join Date: Aug 2009
Location: k3
Posts: 927
Images: 1
My belt has been squeeling to so maybe I'll check both.

motokeen is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange tick / click / knock from under my YJ Incursorio YJ Tech Forum 6 08-07-2009 03:15 PM
clickity tick sound coming from tranny blacksport TJ Tech Forum 3 05-18-2009 06:48 PM
Lifter tick after oil change scotiez TJ Tech Forum 9 04-12-2009 10:39 AM
Annoying tick! 87YJWrangler YJ Tech Forum 7 03-30-2009 08:33 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:54 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC