TJ Blower Motor Resistor - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-12-2012, 02:26 PM   #1
Jeeper
 
Join Date: Jun 2012
Posts: 46
TJ Blower Motor Resistor

I had trouble with a burning paper smell comng from my 98 TJ heater vents on the the lower fan settings. I replaced the blower motor resistor and solved the problem. Here are some pics of the culprit. Notice the oak leaves caked around the element!:
Attached Thumbnails
Click image for larger version

Name:	IMGP2174 (2).jpg
Views:	62
Size:	176.4 KB
ID:	131192   Click image for larger version

Name:	IMGP2173 (2).jpg
Views:	51
Size:	160.7 KB
ID:	131193  


ravensteve9 is offline   Quote Quick Reply
Old 06-12-2012, 02:32 PM   #2
Jeeper
 
wwch99tj's Avatar
 
Join Date: Mar 2011
Location: Felton Delaware
Posts: 4,828
Yup that's very common, I've had to replace mine and now after the leaves fall I'll vaccum the box out

wwch99tj is offline   Quote Quick Reply
Old 06-12-2012, 06:30 PM   #3
Newb
 
Join Date: Jun 2012
Posts: 10
My three lowest speeds arent working
steg is offline   Quote Quick Reply
Old 06-12-2012, 06:36 PM   #4
Jeeper
 
SirGeorgeKillian's Avatar
 
Join Date: Mar 2011
Posts: 1,282
Images: 2
Quote:
Originally Posted by steg
My three lowest speeds arent working
Sounds like a problem at the panel...
__________________
Check out my videos:
http://www.youtube.com/user/TrailRatedCustoms/videos
SirGeorgeKillian is offline   Quote Quick Reply
Old 06-12-2012, 07:41 PM   #5
Jeeper
 
Join Date: May 2011
Location: Great Falls, MT
Posts: 381
Quote:
Originally Posted by steg View Post
My three lowest speeds arent working
I would guess resistor. $20 bucks at o reilys and you'll be right as rain. There's quite a few threads on it and how to swap them out
clarkkent is offline   Quote Quick Reply
Old 06-12-2012, 07:49 PM   #6
Jeeper
 
Join Date: May 2012
Location: Windsor, Maine
Posts: 55
wow, haven't seen one that bad in a while, very common, you can find them for $9 online sometimes, mopar part#
dusman is offline   Quote Quick Reply
Old 06-12-2012, 07:52 PM   #7
Jeeper
 
Leeroy Jeepkins's Avatar
 
Join Date: Nov 2010
Location: Bucks County,PA
Posts: 492
mine looked like that when i replaced my evap coil. i could only get two speeds. cleaned the crap out,cleaned contacts,check continuity and reinstalled. problem free since
Leeroy Jeepkins is offline   Quote Quick Reply
Old 06-12-2012, 08:31 PM   #8
Jeeper
 
Join Date: Dec 2011
Posts: 73
My blower doesnt work when i turn it on any speeds. once in a while it will come on for like 5 seconds. any idea what it could be?
b-mullins1 is offline   Quote Quick Reply
Old 06-12-2012, 08:40 PM   #9
Jeeper
 
wwch99tj's Avatar
 
Join Date: Mar 2011
Location: Felton Delaware
Posts: 4,828
Could be the switch or a loose connection or maybe the blower itself ...
wwch99tj is offline   Quote Quick Reply
Old 06-13-2012, 04:45 AM   #10
Jeeper
 
LiftedTj's Avatar
 
Join Date: Oct 2011
Location: Toledo, Oh (Where Jeeps are born THEN raised)
Posts: 440
Quote:
Originally Posted by b-mullins1 View Post
My blower doesnt work when i turn it on any speeds. once in a while it will come on for like 5 seconds. any idea what it could be?
Fan switch, mine only worked on the 1 setting. Replaced it and all works now
__________________
'Cuz im Mr. OOGIE BOOGIE and you ain't going NO WHERE.
LiftedTj is offline   Quote Quick Reply
Old 06-13-2012, 07:20 AM   #11
Jeeper
 
Join Date: Feb 2012
Location: Ohio
Posts: 229
Had same problem with the resistor looked like a mouse made a nest in it over a weekend it stopped working, changed it, switch and blower motor then to find resistor had shorted out a plug / wire burnt out at the harness next to the firewall.....don't spend money until you check the wires running from fuse boxes.....just saying I spent about $300 bucks and still had to take it to the dealer for repair,
__________________
6rings is offline   Quote Quick Reply
Old 07-16-2012, 11:04 AM   #12
Jeeper
 
Join Date: Jan 2012
Location: Beaumont, TX
Posts: 39
Images: 3
can anyone point me to a how-to on replacing the blower motor resistor please? I have searched but haven't found exactly what i'm looking for. thank you!

__________________
2001 Sport 4.0, 5-speed, D30/D44
31x10.5 BFG KM2 on stock 15" Canyon wheels
100w KC lights mounted near side mirrors
55w KC fogs
Custom stereo: Sony Marine H/U, Infinity mids/highs, Probox JeepJammer (ported) w/ 2 10's
A grinding 2nd gear, lol
crocker_dave is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC