Unsure of how to fix EVAP - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-19-2012, 02:45 PM   #1
Jeeper
 
Join Date: Jul 2010
Location: CT
Posts: 90
Unsure of how to fix EVAP

I have a 2000 4.0 TJ. It failed emissions due to the p0455 and p0420 codes. The o2 sensors and that code have plagued me forever. But my question is with the EVAP. I traced the line front the canister back to the fuel tank and its rotted out, so I guess that is causing it. It does smell of fuel, and I have replaced the gas cap already. The metal line for the evap just plugs into a rubber line when it nears the gas tank and up front when it goes into the canister. there's no clamps or anything either. is this EVAP system high pressure? Could I just get rubber fuel line and replace the metal rotted one? or would this not even be a cheaper fix? im not sure of what to do.

Thanks to anyone who responds.

jwillig11 is offline   Quote
Old 08-19-2012, 04:18 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 34,458
Images: 2
The evap system is not high pressure, I would just go buy a new neoprene hose from your local auto parts store and replace it. No guarantee that is necessarily all you need to get rid of the evap codes of course.

__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote
Old 08-19-2012, 08:42 PM   #3
Jeeper
 
Join Date: Jun 2012
Location: Enfield
Posts: 283
i had the same problem but i put in a new metal brake line and use rubber vac line on each end to hook it up. than reset the comp and been good.
__________________
if it has t*ts or tires,it bound to give you trouble
U.S.M.C. 1371 Iraq Vet
2014 JKUR
2001 tj with things bolted and welded to it
2010 ram cummins power and torque so pretty together
2012 camery se grocery getter
pickupman2500 is offline   Quote
Old 08-19-2012, 08:43 PM   #4
Jeeper
 
Join Date: Jun 2012
Location: Enfield
Posts: 283
i forgot i also have a smoke machine. if the code doesnt clear you might want to take it to a shop and have them smoke it
__________________
if it has t*ts or tires,it bound to give you trouble
U.S.M.C. 1371 Iraq Vet
2014 JKUR
2001 tj with things bolted and welded to it
2010 ram cummins power and torque so pretty together
2012 camery se grocery getter
pickupman2500 is offline   Quote
Old 08-20-2012, 12:12 AM   #5
Jeeper
 
Join Date: Jul 2010
Location: CT
Posts: 90
what else could it be? I have replaced the gas cap. the logical thing seems to be to replace the line that is pretty rotted out. what else could cause that code?
jwillig11 is offline   Quote
Old 08-20-2012, 06:13 AM   #6
Jeeper
 
Join Date: Jun 2012
Location: Enfield
Posts: 283
sending unit leak on top of gas tank. filler neck leak.
__________________
if it has t*ts or tires,it bound to give you trouble
U.S.M.C. 1371 Iraq Vet
2014 JKUR
2001 tj with things bolted and welded to it
2010 ram cummins power and torque so pretty together
2012 camery se grocery getter
pickupman2500 is offline   Quote
Old 08-20-2012, 07:40 AM   #7
Jeeper
 
ajorosa's Avatar
 
Join Date: Aug 2010
Location: N.J.
Posts: 570
The ends of all the vent lines on top of your gas tank are most likely dry rotted and loose. Also check the fuel pump ring on the outside of the tank. It tightens like a large jar lid. All of this solved my code issues and a gas smell. It requires dropping your tank.
__________________
"You got to cry without weeping
Talk without speaking
Scream without raising your voice"

Never be afraid to try something new. Remember, a lone amateur built the Ark. A team of engineers built Titanic.
ajorosa is offline   Quote
Old 08-20-2012, 08:09 PM   #8
Jeeper
 
Join Date: Jul 2010
Location: CT
Posts: 90
Thanks guys that seems like more of the issue. I have noticed that the smell of gas is definitely more in the back of the jeep.
jwillig11 is offline   Quote
Old 08-20-2012, 08:56 PM   #9
Jeeper
 
Join Date: Jun 2012
Location: Enfield
Posts: 283
i dont know what kind of seal it is. if it is a o ring for the sending unit(fuel pump) than mke sure you coat it in grease not a heavy amount before installing it. it will help with sealing it

__________________
if it has t*ts or tires,it bound to give you trouble
U.S.M.C. 1371 Iraq Vet
2014 JKUR
2001 tj with things bolted and welded to it
2010 ram cummins power and torque so pretty together
2012 camery se grocery getter
pickupman2500 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC