Update on submerged TJ - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-31-2013, 11:38 PM   #1
Newb
 
KENROD's Avatar
 
Join Date: Mar 2013
Posts: 4
Update on submerged TJ

Well,

All fluids are changed, and the motor is turning over good. New plugs, wires, dist cap & button. I am getting fuel to the rail. Now I'm getting no fire to the coil. I had my buddy pull me around to get fluids pumping. I downloaded the manual and read up on the ignition. I haven't had a chance to put a volt meter on it yet. My next move will be to change the the CPS, if still no fire, change Coil, and then computer if the coil don't work. Any suggestions would be great!

Problem 2
My entire dash quit working. All of the fuses look good, I asume its the connection behind the cluster. Does that controll the heater/ blower controlls as well? I't isn't working either. All of my lights, turn signals etc.. work just a normal.

One positive is, I'm learning my way around the T.J. Thank you all again.

Ken

KENROD is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC