Weird 4WD Light Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-24-2011, 10:46 PM   #1
Jeeper
 
Join Date: Feb 2011
Location: Michigan
Posts: 431
Weird 4WD Light Problem

So I was reading around the forum and found out that sometimes the 4WD light on the dash doesn't work because it's burnt out. However, I took the dash apart and inspected behind the gauges. The bulb in the part- time slot is there and doesn't appear to be blown but still doesn't work and there is no bulb whatsoever for the full time 4WD. Would a missing Full Time bulb affect the Part Time light to come on?

2dmud is offline   Quote Quick Reply
Old 03-24-2011, 10:49 PM   #2
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,138
Wranglers dont have full time 4WD thus no bulb needed.

__________________
Jp90Talon is offline   Quote Quick Reply
Old 03-24-2011, 10:50 PM   #3
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,899
My 4WD light stopped a long time ago and glad it did. If you do not know your in 4WD you should not be in one. Pay attention to how you drive is my motto.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 03-24-2011, 11:01 PM   #4
Jeeper
 
Thebandit1980's Avatar
 
Join Date: Oct 2010
Posts: 103
On a yj the 4x4 light not coming on can mean you don't have 4x4. The vacuum actuator on the from axle may not be working properly. Not sure if a tj is the same.....
Thebandit1980 is offline   Quote Quick Reply
Old 03-24-2011, 11:06 PM   #5
Jeeper
 
Thebandit1980's Avatar
 
Join Date: Oct 2010
Posts: 103
Quote:
Originally Posted by Thebandit1980
On a yj the 4x4 light not coming on can mean you don't have 4x4. The vacuum actuator on the from axle may not be working properly. Not sure if a tj is the same.....
I meant "front axle" ; )
Thebandit1980 is offline   Quote Quick Reply
Old 03-24-2011, 11:06 PM   #6
Jeeper
 
GroundHawg's Avatar
 
Join Date: Apr 2010
Location: northeast ohio
Posts: 2,274
First, verify that 4wd actually engages. 4hi is tough to tell sometime, but 4lo...you'll know

If 4wd engages and disengages correctly and the bulb is ok...

There is a switch on the TC. Pull it and get some contact cleaner and clean it up. It's located near the output shaft, by the top. You'll see a wire going to it
GroundHawg is offline   Quote Quick Reply
Old 03-25-2011, 06:43 AM   #7
Jeeper
 
Join Date: Feb 2011
Location: Michigan
Posts: 431
I meant the 4lo light lol not full time. I'm going to try and clean it and see what happens
2dmud is offline   Quote Quick Reply
Old 03-25-2011, 09:23 AM   #8
Jeeper

WF Supporting Member
 
99jeeper's Avatar
 
Join Date: Feb 2011
Location: nothern michigan
Posts: 449
Images: 3
my light dont come on either,i unplugged the switch on the transfercase,its a 2 wire plug,i took a jumper wire across the plug and the dash light came on,soooo i need a new switch just havent broke down to buy a new one. their about 25.00 at autozone
__________________
99jeeper is offline   Quote Quick Reply
Old 03-25-2011, 10:24 AM   #9
Supporting jeeper!

WF Supporting Member
 
Mikekaz1's Avatar
 
Join Date: Nov 2010
Location: Springfield ma
Posts: 3,860
My light on my 2000 tj doesn't work either. But everything engages correctly. So I'm not worrying about it
Mikekaz1 is offline   Quote Quick Reply
Old 03-25-2011, 02:38 PM   #10
Jeeper
 
GroundHawg's Avatar
 
Join Date: Apr 2010
Location: northeast ohio
Posts: 2,274
Quote:
Originally Posted by 99jeeper
my light dont come on either,i unplugged the switch on the transfercase,its a 2 wire plug,i took a jumper wire across the plug and the dash light came on,soooo i need a new switch just havent broke down to buy a new one. their about 25.00 at autozone
Yeah sometimes cleaning doesn't work. Replacement of the switch is next :P

GroundHawg is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Fog Light Switch Problem CraigS1001 TJ General Discussion Forum 11 07-08-2011 07:23 AM
Weird starting problem. Skumps TJ Tech Forum 0 02-08-2011 05:41 PM
Weird Light Problem csamn2007 General Jeep Discussion 1 01-09-2010 02:24 PM
Weird flasher problem... GrnTJ TJ General Discussion Forum 4 08-11-2007 12:00 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC