Weird A/C Problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 08-30-2011, 05:45 PM   #1
Join Date: Sep 2010
Location: Tuscaloosa, AL
Posts: 13
Weird A/C Problem

I have an '01 TJ that has a new problem. A week ago the 2 and 3 settings on my A/C went out. I understand that to be a typical problem and didn't really care that much since the 1 and 4 setting was still working.
Yesterday I turned on my Jeep and the 1 and 4 setting aren't working either, but when I switch it back to the 1 setting it gets really stiff and hard to put all the way down into the 1 spot. This had not happened before now. I can feel cold air in the vent, but it's coming out (on all settings) even slower than if it were on 1.
I couldn't find anyone else that was having the problem with the switch being hard to get back into the 1 setting so I thought I would start this new thread.
Any help or suggestions would be appreciated.

sglisson is offline   Quote
Old 08-30-2011, 07:01 PM   #2
fire239's Avatar
Join Date: Oct 2010
Location: MEMPHIS, TN
Posts: 367
Sounds like a bad switch. My TJ has slide controls, (1997 and 1998) but i understand that when these switches go bad they get hot and melt inside. This may cause it to be hard to turn.

fire239 is offline   Quote
Old 08-31-2011, 11:20 AM   #3
Join Date: Sep 2010
Location: Tuscaloosa, AL
Posts: 13
Thanks. Now I'll start looking up how to replace this. Hopefully it's not too difficult.
sglisson is offline   Quote

a/c , air conditioner , air conditioning , switch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird problem after installing gas skid plate 99TJCrawler TJ General Discussion Forum 2 02-21-2011 10:00 PM
Weird Wheel Offset Problem DocG2828 TJ Tech Forum 7 02-14-2010 03:37 PM
Weird Light Problem csamn2007 General Jeep Discussion 1 01-09-2010 03:24 PM
'97 Wrangler Cold Idle / Load Flooding Problem brad07x TJ Tech Forum 1 12-19-2009 12:10 AM
Shifting Problem lonerider6 YJ Tech Forum 6 06-01-2008 04:51 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:23 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC