Weird Electrical Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-31-2011, 08:52 PM   #1
Jeeper
 
zpratt4's Avatar
 
Join Date: Sep 2007
Location: Knoxville, TN
Posts: 257
Weird Electrical Problem

I recently had my heater core replaced so the whole dash of my TJ had to come out. After I got it back, whenever I turn my lights on, my gauges fall, the backlight for my gauges goes off, and the turn signal lights and high beam light come on. If I turn my lights off, everything works again. Also, when the lights are on, the light that shines in the driver's side floor comes on.

It is definitely more than just the standard Jeep problem of the gauges falling. I have had that problem in the past, and I already tried fixing it that way.

Does anybody have any ideals at all of where to look or what the problem might be? I would appreciate any ideals at all.

__________________
GO VOLS!
zpratt4 is offline   Quote Quick Reply
Old 05-31-2011, 09:17 PM   #2
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,131
Someone forgot a ground or two or three. What's happening is the headlights are backfeeding into the other circuits when turned on, looking for a ground path.

For a quick peek, on each side of the bottom of the dash look for a bunch of black wires screwed/bolted into the sheet metal. Those are the various grounds for the interior.
Will be a bunch, all going to one screw/bolt.

But hey if you paid someone to do the heater core, take it back and let them correct their boo boo.

__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 06-01-2011, 05:37 PM   #3
Jeeper
 
zpratt4's Avatar
 
Join Date: Sep 2007
Location: Knoxville, TN
Posts: 257
Quote:
Originally Posted by Shelby427 View Post
Someone forgot a ground or two or three. What's happening is the headlights are backfeeding into the other circuits when turned on, looking for a ground path.

For a quick peek, on each side of the bottom of the dash look for a bunch of black wires screwed/bolted into the sheet metal. Those are the various grounds for the interior.
Will be a bunch, all going to one screw/bolt.

But hey if you paid someone to do the heater core, take it back and let them correct their boo boo.
Thank you for responding. I am definitely going to look into it. But there is no way I am taking it back to the mechanic who replaced my heater core. When I got it back the first time, I had no A/C or heat, it was just warm air and my fog lights had not been hooked back up. I fixed the fog lights and when I took it back to get the A/C and heater fixed, he fixed that problem but I got it back the fog lights were disconnected again and now the dash problem.

Thanks again for your help
__________________
GO VOLS!
zpratt4 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 TJ Electrical Problem Dennis G TJ General Discussion Forum 14 03-01-2012 04:30 PM
Electrical Problem vonulm TJ General Discussion Forum 3 03-12-2011 01:12 PM
Electrical problem Dave Bee TJ Tech Forum 0 03-27-2010 08:58 AM
Electrical problem tee895 TJ Tech Forum 7 05-14-2009 05:30 PM
tj electrical problem mick laporta TJ Tech Forum 17 03-24-2007 04:50 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC