Weird RPM issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-14-2012, 06:07 PM   #1
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 81
Weird RPM issues

My RPM has been weird lately. If I'm moving and I disengage the clutch, sometimes the RPM will drop and stay at 1000, but usually it'll hang just below 1000 or sometimes drop below Idle RPM.
When just sitting at a stop, the idle sometimes feels a tad rough as well.
My gas mileage also took a small hit since this has been happening, maybe 1-3 mpg. I cleaned my IAC and throttle body, replaced the Crank case vent connections from the front of the crank case to the side of the throttle body, and yet the problem still persists. I know that when I push the clutch in, my RPM should drop and stay at 1000, cause it did that for the first year and a half that I owned it.
I have a 1999 4cyl with the AX-5.

What could the problem be?

__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote Quick Reply
Old 04-15-2012, 08:52 AM   #2
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 81
Anyone?

__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote Quick Reply
Old 04-15-2012, 09:51 AM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,095
Throttle position sensor starting to go bad.
Would explain the erratic idle and fuel consumption problems.

If it's not sending the correct signal to the computer, it affects the IAC position, and how much fuel flows to the injectors.

Only other thing I can think of, if it's equipped with one, would be an EGR valve hanging up at times. Acts like a vacuum leak, and the computer tries to compensate by dumping more fuel.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 04-15-2012, 03:28 PM   #4
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 81
I'll look into replacing it then. I pulled both the IAC and the TPS, cleaned the plunger on the IAC and contacts on both, but it didn't help. These seem to be the only issues, I don't really have any hesitation outside of the normal 4-popper sluggishness, or misfiring.

Thanks
__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:02 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC