Weird stall? what the heck? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-26-2011, 10:43 PM   #1
Jeeper
 
SaharaGB's Avatar
 
Join Date: May 2011
Posts: 21
Weird stall? what the heck?

Ok,
this could just be me being stupid OR something else. i took in my 98 sahara to the 'stealership" on tuesday just to get a once over of everything after i bough t this jeep. It has 48000 miles on it and was TRULY taken care of(even told that by the mechanic at the dealership). So after their 40 point inspection, he said my car is in EXCELLENt condition , but that my radiator needed to be replaced, (which i did). if some of you recall, i've only had the jeep three weeks. i let the jeep sit a few days, and tonight decided to start it up to move it back into my driveway for the night. I really didn't let it (warm up) per say as it is 45 degrees here in titletown. The temp gauge was def at or below 100 on the gauge.
i live on a street that curves around, so just a little acceleration to get out of my driveway, then a slow acceleration to a the small curve on my street than i pretty much have to coast (AUTO transmission) to the stopsign. As i being my coast the jeep starts to shake and ten stalls. this has happened to me twice before, both in teh EXACT same spot. i have to throw the jeep back in park and fire thh engine again, it always starts up, and then runs fine the rest of the day. i never seem to have this problem if I am using the jeep regualrly.
AM i just STUPID and not realizing i need to let this engine warm up as it IS twelve years old? or is this a precurser to something else?

SaharaGB is offline   Quote Quick Reply
Old 05-27-2011, 12:25 AM   #2
Jeeper
 
Black98's Avatar
 
Join Date: Nov 2010
Location: South East PA
Posts: 379
The engine should not stall like that, it sounds like some type of sensor is dirty or has a loose wire that is somehow causing the computer to not maintain idle properly.

Black98 is offline   Quote Quick Reply
Old 05-27-2011, 08:45 AM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,131
Pull the IAC out of the throttle body, clean the tip on it and the passage way it goes into on the throttle body, with carb cleaner.

Most likely it's got some build up and the IAC is hanging up when it's cold.

While you are there, open the butterfly on the throttle body and look for a deposit ring below it. This can cause the butterfly to not close fully. More carb cleaner, and an old toothbrush if necessary.


IAC, Idle Air Control
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 05-27-2011, 09:05 AM   #4
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 36,711
That's one problem with older vehicles with low miles, means they been sitting a lot. Similar thing happened to a friend with his 2000 @ 50k. It never really stalled but ran like crap. First thing we did was pull the TB and IAC like Shelby said and cleaned everything up. That did not work. He ending up having a clogged fuel filter or something along those lines. Ended up
dropping the gas tank and replacing the pump and filter if I recall. I'll call him later cause I really don't remember the outcome but whatever he has done fixed the issue. Jeep ran like a champ.
kjeeper10 is online now   Quote Quick Reply
Old 05-27-2011, 09:13 AM   #5
Jeeper

WF Supporting Member
 
jp2611's Avatar
 
Join Date: Aug 2010
Location: Fort Wayne IN
Posts: 6,518
It appears everyone else has already jumped in--my .02 ..........no computer controlled/fuel injected vehicle should have to "warm-up" 'cept in EXTREME conditions. just sayin'
jp2611 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When jeep has ran awhile reverse wants of stall or it does stall- help please!!!! WensToy TJ General Discussion Forum 3 05-22-2011 01:21 PM
Stall 08XUnlimited JK General Discussion Forum 6 10-06-2010 08:35 AM
Recently developed rough idle and stall '87 YJ w/i6 Hardwater Kiter YJ Tech Forum 0 08-24-2010 09:53 PM
This was weird!! soupy8728 YJ General Discussion Forum 8 09-26-2007 01:11 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC