Weird turn signal/electrical gremlins - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-04-2010, 02:08 AM   #1
Jeeper
 
Dr Gonzo's Avatar
 
Join Date: Jul 2010
Posts: 117
Weird turn signal/electrical gremlins

My '98 TJ sometimes shows a solid left blinker indication sometimes when the vehicle isn't moving, seems to happen when the break pedal is depressed. I have no idea what could cause that to happen. As additional information, if it helps, the auto-cancel doesn't work when turning right (have to manually move it back), and if the wheel isn't exactly centered the stick doesn't want to click down to signal left.

Any idea what this could be, or if it could be indicative of another problem? It's also starting hard, but that's probably completely unrelated.

Dr Gonzo is offline   Quote Quick Reply
Old 08-04-2010, 07:16 PM   #2
Member
 
Join Date: Oct 2009
Location: San Jose Calif.
Posts: 1,006
Sounds like a bad stalk to me. There has been lots of threads on the subject of replacing that stalk on this forum.

03 RUBI is offline   Quote Quick Reply
Old 08-04-2010, 08:39 PM   #3
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
i have a similar issue, after replacing a busted ignition i get the left blinker go on when i come to a stop but that's only if i have used the left blinker before using the brake, i have to actually turn on the blinker and turn it off again.
__________________
Dear Algebra, Please stop asking us to find your X. She's never coming back and don't ask Y.
Jma20a is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Tail light issue.. HELP? BBjmc TJ General Discussion Forum 21 11-30-2013 05:39 PM
Heartland Jeep club at LBL on July 11th... ;) InfernoGirl Kentucky Jeep Forum 110 08-20-2010 05:13 PM
Turn signal problem gtguyonli TJ Tech Forum 7 07-06-2010 10:55 PM
Turn Signal Grounding issue? MrMiyagi TJ Tech Forum 1 09-15-2009 05:26 PM
Weird Turn Signal Issue toddyfresh TJ Tech Forum 0 09-03-2008 07:31 PM



» Featured Product

All times are GMT -5. The time now is 05:59 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC