what did i do?!?! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-01-2012, 11:36 PM   #1
Newb
 
Join Date: Sep 2012
Posts: 2
what did i do?!?!

so i was driving from maryland to michigan and on the trip the dog shifted me into neutral on 75N... the car over heated, my belt slipped off and my battery played dead. we got it towed where we were going. i have replaced the water pump, replaced my thermostat back in july. it is august 30-sept 1 now and after hooking what i believe is everything back up the symptoms are, it runs less that a 100*F sometimes a little harder when i do that little lift the accelerator thing to rev the engine, i have yet to drive it. belt hasnt slipped yet, and for some reason only when i shut it off i get a trace amount of smoke coming off... only when i shut it down. so... no obvious leaks and yeah, utterly confused. ill check again in the morning see if anything is resolved. oh, i did spill some coolant all around when i filled the radiator back up. i dropped the thing twice so if that helps. any ideas?

johntaggart is offline   Quote Quick Reply
Old 09-02-2012, 03:47 PM   #2
Jeeper
 
coolbreeze's Avatar
 
Join Date: Jul 2009
Location: Redding, Ca
Posts: 864
Other than not letting the dog drive anymore, I have no idea. Good luck.

__________________
2004 Black X 4.0, auto, 3.73's, soft top 31-10.5-15 Toyo A/T's on 8" Ultra 175's, 2" Teraflex BB.
coolbreeze is offline   Quote Quick Reply
Old 09-02-2012, 04:02 PM   #3
Jeeper
 
Join Date: May 2012
Location: Clemson, SC
Posts: 532
A little more info is needed before we can even begin to help... what bred of Dog?
__________________
2010 Wrangler JKU
cphilip is offline   Quote Quick Reply
Old 09-02-2012, 06:09 PM   #4
Jeeper
 
SCHOOLBUSLEO's Avatar
 
Join Date: Jun 2012
Location: wisconsin
Posts: 27
You may have just over revved the engine slipping it into neutral when driving down the highway, which may have caused the belt to fly off if it was in bad condition. I know that unless you rinse antifreeze thoroughly from the engine area it will smell & smoke for awhile. hopefully you dont have any major issues. good luck & pat the dog that a boy, hes your buddy!
__________________
LIFES A BEACH, BUILD A HUT ON ONE!!!!!
SCHOOLBUSLEO is offline   Quote Quick Reply
Old 09-06-2012, 03:13 PM   #5
Newb
 
Join Date: Sep 2012
Posts: 2
Replaced the water pump and checked the thermostat. If my head gasket is blown how much do you think the cost will be?
johntaggart is offline   Quote Quick Reply
Old 09-06-2012, 03:22 PM   #6
Jeeper

WF Supporting Member
 
Sccafire's Avatar
 
Join Date: Oct 2011
Location: 92 miles from the Rubicon Trail
Posts: 775
According to repair manual it takes 4.9 hours (6cyl motor) to repair. At 100 an hour for shop rate thats approx $500 in just labor.
__________________
Scott
Sccafire is offline   Quote Quick Reply
Old 09-06-2012, 03:44 PM   #7
Jeeper
 
tbensor's Avatar
 
Join Date: Feb 2012
Posts: 1,155
Running less that 100 tells me the tstat may not be closing or you have a big air bubble. I am not sure if blown head gasket would cause that or not. I'll let someone else chime in on that.
__________________
My Toys
2003 RED Jeep Wrangler X - Can't stop adding stuff and updating.
2014 White Jeep Liberty Sport
2011 Carbon Black GMC Yukon Denali
2007 Black GMC Sierra 2500HD 4x4 Duramax/Allison
2007 Keystone Laredo 284BHS TT
tbensor is offline   Quote Quick Reply
Old 09-06-2012, 04:38 PM   #8
Jeeper
 
Join Date: Nov 2011
Posts: 138
I agree it might be an air bubble from when the water pump was replaced.

c_goodnow is offline   Quote Quick Reply
Reply

Tags
battery , belt slip , radiator , radiator fluid , water pump

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC