What froze or broke today... - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-21-2012, 09:29 PM   #1
Jeeper
 
srad600's Avatar
 
Join Date: Apr 2011
Location: Tabernacle, NJ
Posts: 1,771
What froze or broke today...

Today was my first time with this Jeep/setup in the snow. Wasnt a major snow storm, just about 2 inches. I left for work at 515am, mostly just snow at this point. I made it to work fine with out the use of 4wd. When I got to work I had to do some creative parking since my lot was being plowed. I slipped into 4hi and parked. I left it in 4hi during my 9 hour shift (I didnt intend to but I forgot). When I came out, I started the jeep let it warm up while I tried like hell to get the sheet of us that in cased the entire drivers side(it sleeted/freezing rained all day, mainly blowing right onto my drivers side). Hoped in, started to drive away still not realizing Im in 4hi(my indicator light hasnt worked since I bought the Jeep). I immediately noticed the Jeep was pulling hard to the drivers side. I got out to take a look at some stuff trying to figure it out. I found nothing and hopped back in, noticed that I was in 4wd and put it back in 2. No more pulling...pulled over into a parking lot and realized its only in 4wd that this happens. I drove the rest of the home in 2wd and no trouble. I cant get the ice off of everything nor warm it up enough to "thaw it out:


What should I check that could make it pull hard to the left only in 4wd?

Jeeps in my sig, no accidents, slides, curbs bumps or anything on the way to work or home.

__________________
The Budget Brawler. AKA Berta
97 sport 4.0 5 spd
6" Long arm 35" MTRs
HP30-Eaton E locker D44-Detroit locker-4.88 Ten Factory Chromo shafts.
KC/Hella, Engo 12k, LED rock lights, "train" horns, Home made-Hand Throttle, OBA, Etc etc.
srad600 is offline   Quote
Old 01-22-2012, 02:13 PM   #2
Jeeper
 
srad600's Avatar
 
Join Date: Apr 2011
Location: Tabernacle, NJ
Posts: 1,771
Bump? Gonna warm up tomorrow so i can look at it then.
__________________
The Budget Brawler. AKA Berta
97 sport 4.0 5 spd
6" Long arm 35" MTRs
HP30-Eaton E locker D44-Detroit locker-4.88 Ten Factory Chromo shafts.
KC/Hella, Engo 12k, LED rock lights, "train" horns, Home made-Hand Throttle, OBA, Etc etc.
srad600 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Officially a JEEP owner today rico334 TJ General Discussion Forum 26 01-16-2015 09:35 AM
What did you order/buy today? Barmanvarn General Jeep Discussion 5 12-11-2011 06:42 PM
Look what i broke today... firstresponder YJ General Discussion Forum 4 09-11-2011 09:27 PM
Tops switch today mishel JK General Discussion Forum 4 06-23-2009 02:00 PM
Today is my Anniversary! jeeptales Off-Topic 13 04-03-2006 02:44 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:31 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC