What I did to my TJ today - Page 608 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-10-2013, 07:06 PM   #18211
Supporting Member

WF Supporting Member
 
Holton345's Avatar
 
Join Date: Jun 2013
Location: Yazoo City, MS
Posts: 1,237
In my ongoing battle to fix up my "discount" 2003 Sport I cannibalized more from my 2003 SE.

The swing-away tire carrier is weakly designed and poorly made. It is Chinese, so par for the course...

When I bought this rig the carrier allowed the 33x12.5" tire to sag back about an inch or more from vertical at the top of the tire. After a towing situation (forced on me by circumstance) yanked that back and seized the frame screws this POS bumper needed to be trashed.

I had to take it in to have the pros remove the two frame rail bolts (in the bottom at the ends). One took an impact wrench going full guns about five full minutes to come free. The other one snapped off.

A welder managed to get it out, but only after he drilled a small access hole on the passenger side frame rail. (It is not hurting anything where it is.)

After all that nonsense, it turns out that the minor rear-ending the jeep suffered in 2003 was fixed pretty well, but the last foot or so of one or both rails is slightly bent in toward the other. At the tip of the rails they are off by about 3/16", which would explain why the two bolts were so badly seized! Crap, what a lot of lateral pressure on threads!

I modified my very nice AtoZ Fabrications rear bumper on my dead SE with a Dremel and a grinder stone head. I arced in the two frame strap holes just enough to allow the screws to run into the thread straight and not way off kilter like the last set were forced to be.

Now it is solid as all get out.

But I have no rear tire carrier.

Solution (temporary): cannibalize the carrier from the SE. Use the SE's spare until I can afford one of Zach's excellent bumpers with the tire carrier.

So today I relocated both and ran the wires and set up the contacts in the tailgate box for the 3rd brake light.

DOH! The PO Herculined over the contacts on the tub fender well! IDIOT!

I cleaned that up. The wife and I set to testing everything and: no light.

I changed to a known-good bulb. Still no light. All the wiring from the gate to the light is fine.

How do I test the line from where it branches off from the main brakes? Where would that be on an '03? Will I have to remove the plastic fender bottom that covers up that part of the evap system that lives up in there?

Suggestions?

I also preferred how my old tailgate latch and lock felt - much more positive with the key and with opening/closing. So I also swapped those from one jeep to the other.

Tonight I will go after fixing the MFS because both these jeeps have the dreaded fogs that come on and stay on all night if you do not go out and press the stalk in toward the steering column. The one I am fixing up will not turn off at all. Ever. It has no fogs but that dang green dash light burns 24/7. Tonight I will attempt to fix the one in the SE. If that goes well I will either swap the entire system or do the Sport as well. I will probably go with simply doing the one and swapping them. I can bring the other one in and do it later, since the SE has no motor or battery.

Any advice on that. I will be using this writeup as a basic guide, though I know I could find that there is some other problem when I get the thing opened up...

Advice for the 3rd brake light? Experiences? Where it that junction? How do I run the wires from that point back to see if they are cut or disconnected? ALL OTHER LIGHTING ON THIS TJ FUNCTIONS PERFECTLY. Could it be a pulled fuse? What fuse is it on, and what shares that fuse. (If you know this, please answer even though I probably answered my own question since all the other lighting seems to be fine. I just want to know what fuse and what shares that fuse with the 3rd brake light.)

Thanks.

Swapping the front bumpers tomorrow, probably...

__________________
Wade

2003 Shale Green TJ Sport
2013 Black JK Sport S
A Jeep Wrangler is like a set of Legos for adults.
Holton345 is online now   Quote Quick Reply
Old 07-10-2013, 07:18 PM   #18212
Supporting Member

WF Supporting Member
 
Holton345's Avatar
 
Join Date: Jun 2013
Location: Yazoo City, MS
Posts: 1,237
Yeah, I realized my mistake just now and re-posted my 3rd brake light wiring question to the proper forum. (But if you read it and have any ideas please chime in. I suck at electronics and electrics but am willing to learn.)

__________________
Wade

2003 Shale Green TJ Sport
2013 Black JK Sport S
A Jeep Wrangler is like a set of Legos for adults.
Holton345 is online now   Quote Quick Reply
Old 07-10-2013, 07:23 PM   #18213
Jeeper
 
DBoat's Avatar
 
Join Date: Jul 2012
Location: The Big D
Posts: 1,472
Quote:
Originally Posted by ltdanyj View Post

Don't know yet... Suggestions?

Oh, and yes- Auto... 42rle
I don't have any, I was hoping to get,one from you.
DBoat is offline   Quote Quick Reply
Old 07-10-2013, 08:16 PM   #18214
Jeeper
 
phrak's Avatar
 
Join Date: Jul 2013
Location: Indy
Posts: 81
Quote:
Originally Posted by justin89 View Post
yup I got caught while in the store last weekend with a sunny day and then BAM thunderstorm out of no were with all my things I bought in the back of the jeep
Fortunately for me, I was just grabbing lunch with some friends. I did put the top up, but I figured without the doors there was no sense in installing the side/rear windows. It wasn't too horrible but, despite it being July, the rain is still quite cold.
phrak is offline   Quote Quick Reply
Old 07-10-2013, 08:18 PM   #18215
Newb
 
Join Date: Jul 2013
Location: Maryland
Posts: 5
Towed my boat out and and scrapped the bottom. My jeep is a worker.
kiteboarder is offline   Quote Quick Reply
Old 07-10-2013, 08:21 PM   #18216
Jeeper
 
HIZENBERG's Avatar
 
Join Date: May 2013
Location: Sachse
Posts: 49
Quote:
Originally Posted by ltdanyj View Post
So latest updates on my rig!!!

This week, the jeep first got a Genright rear crossmember cap:

Of of the biggest issues with wheeling an LJ compared to a TJ is the rear departure angle. This is a good fix, without doing something crazy like a wheelbase stretch! I ended up doing with the built in receiver hitch, not because I plan on towing anything, but so that I have access to my hitch mount accesories (bike rack and a cargo basket). The quality of the piece is top notch!!! It wraps around the crossmember, and requires you to pull/re-install the rear body mounts. The only modification required was a cut in the stock crossmember to clear the receiver hitch, but everything else lined up perfectly.

Next, while I wait the SIX MONTHS for my new set of wheels, I purchased a set of spidertrax wheel spacers to give me back some more steering, and allow for a little more uptravel.. The "look" was just an added benefit:

Next up, I have all the parts to finally put a CB in the rig, including a 102" whip antenna. Also, I've experienced a couple anomalies from the transmission, so the search for a good condition used replacement has begun. The plan is to swap in the used transmission, and then send off the original for a performance build when time and money allows.

Stay Tuned!!!
That run stick people sticker damn near made me piss my pants. Rofl
HIZENBERG is offline   Quote Quick Reply
Old 07-10-2013, 08:22 PM   #18217
Jeeper
 
HIZENBERG's Avatar
 
Join Date: May 2013
Location: Sachse
Posts: 49
Quote:
Originally Posted by SpoiledRotten View Post
Before:

After:

If you didn't see, I removed the side steps and had a set of rock sliders made for it. I also painted my chrome plated grill inserts to match the rest of the Jeep.

Now my sliders match my front and rear bumpers. They are also bedlined.
That looks sweet.
HIZENBERG is offline   Quote Quick Reply
Old 07-10-2013, 08:23 PM   #18218
Jeeper
 
HIZENBERG's Avatar
 
Join Date: May 2013
Location: Sachse
Posts: 49
Quote:
Originally Posted by hcarlgolden View Post
Ok so today I finally got some pics. So here they are.
Air vent Part 1 of 2
Air vent Part 2 of 2

One of the speaker covers.

Trim piece behind passenger grab bar.

Passenger Grab Bar

Trim around Speedometer Cluster. I have only goten the Black done on it. This one piece will be 2 colors. The other will be Blue of course.

Front of the Glove Box.

Passenger Airbag Cover.

Some more pieces in various stages of painting and clear coating. I put back the shifter shroud (thingy) today. It looks great. Just one problem. Now it makes the shifter boot look like crap.
Looks good. I'm doing the same to my blue baby
HIZENBERG is offline   Quote Quick Reply
Old 07-10-2013, 09:53 PM   #18219
Jeeper
 
hcarlgolden's Avatar
 
Join Date: Jul 2011
Location: Western NC
Posts: 265
Images: 3
Send a message via ICQ to hcarlgolden Send a message via AIM to hcarlgolden Send a message via MSN to hcarlgolden Send a message via Yahoo to hcarlgolden Send a message via Skype™ to hcarlgolden
Quote:
Originally Posted by HIZENBERG View Post
Looks good. I'm doing the same to my blue baby
Cool man if you are you might want to check out this thread

http://www.wranglerforum.com/f5/tire...it-152938.html
__________________
03 Wrangler X ERH 4.0L Power Tech I-6 Engine
Build Date: July 24, 2002
Blue Jeep Club Member #384
hcarlgolden is offline   Quote Quick Reply
Old 07-10-2013, 09:57 PM   #18220
Jeeper
 
hcarlgolden's Avatar
 
Join Date: Jul 2011
Location: Western NC
Posts: 265
Images: 3
Send a message via ICQ to hcarlgolden Send a message via AIM to hcarlgolden Send a message via MSN to hcarlgolden Send a message via Yahoo to hcarlgolden Send a message via Skype™ to hcarlgolden
Mistry Wire

Along with all the other stuff I did do today I found a wire (set of wires) not connect to anything just hanging just behind the radio head unit but hangs loose down to the right near the fuse panel behind the glove box. I took 2 photos, one of the connector and the other showing the wires and coloring. Can anyone clue me into what this is for?

__________________
03 Wrangler X ERH 4.0L Power Tech I-6 Engine
Build Date: July 24, 2002
Blue Jeep Club Member #384
hcarlgolden is offline   Quote Quick Reply
Old 07-10-2013, 10:00 PM   #18221
Keep Calm & Chive On!

WF Supporting Member
 
unlimitedsoldier's Avatar
 
Join Date: Apr 2013
Location: Raleigh, NC
Posts: 681
Quote:
Originally Posted by hcarlgolden View Post
Along with all the other stuff I did do today I found a wire (set of wires) not connect to anything just hanging just behind the radio head unit but hangs loose down to the right near the fuse panel behind the glove box. I took 2 photos, one of the connector and the other showing the wires and coloring. Can anyone clue me into what this is for?

umm do you have a after market head unit in your jeep by any chance? because that looks like some speaker wire and the small blue (carolina blue) one looks like it can be a remote wire for an stock amp for the stock subs that are in the center consoles.

I am not sure if thats what it is but just a hunch
__________________

OATH KEEPER!!
2004 LJ Build Thread
http://www.wranglerforum.com/f322/20...ld-258949.html
unlimitedsoldier is offline   Quote Quick Reply
Old 07-10-2013, 10:53 PM   #18222
Jeeper
 
tsteb's Avatar
 
Join Date: Apr 2012
Location: North Carolina coast
Posts: 915
Got all lights mounted for uwharrie. Probably dont even need headlights.... sorry for crappy iPhone pic. Glad I have friends who are electricians.

12" led light bar on hood
2 4" led round fog lights on sides

Click image for larger version

Name:	image-1558307981.jpg
Views:	134
Size:	120.5 KB
ID:	271256

Kc driving lights that were sitting in the garage


Click image for larger version

Name:	image-881437106.jpg
Views:	122
Size:	141.2 KB
ID:	271257
tsteb is offline   Quote Quick Reply
Old 07-10-2013, 10:59 PM   #18223
Jeeper

WF Supporting Member
 
Turbostixxx's Avatar
 
Join Date: Sep 2012
Location: Richmond, Virginia
Posts: 19,732
Quote:
Originally Posted by tyback View Post

Put mine in and the lights work but not the lights left on indicator. Any suggestions?
Fuse 14 or 19...
__________________
_______
/l
,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

1997 Wrangler SE:4" Lift; 33x11x16; Q9000 Winch
Turbostixxx is offline   Quote Quick Reply
Old 07-10-2013, 11:17 PM   #18224
Jeeper
 
hcarlgolden's Avatar
 
Join Date: Jul 2011
Location: Western NC
Posts: 265
Images: 3
Send a message via ICQ to hcarlgolden Send a message via AIM to hcarlgolden Send a message via MSN to hcarlgolden Send a message via Yahoo to hcarlgolden Send a message via Skype™ to hcarlgolden
Quote:
Originally Posted by tsteb View Post
Got all lights mounted for uwharrie. Probably dont even need headlights.... sorry for crappy iPhone pic. Glad I have friends who are electricians.

12" led light bar on hood
2 4" led round fog lights on sides

Attachment 271256

Kc driving lights that were sitting in the garage


Attachment 271257
Looks good man. I have almost the same light setup, rear lights, KC lights on the hinges. I just need the hood light bar. Do you have better / day pics of the light bar?
__________________
03 Wrangler X ERH 4.0L Power Tech I-6 Engine
Build Date: July 24, 2002
Blue Jeep Club Member #384
hcarlgolden is offline   Quote Quick Reply
Old 07-10-2013, 11:25 PM   #18225
Jeeper
 
JReed615's Avatar
 
Join Date: May 2012
Location: Michigan
Posts: 700
Quote:
Originally Posted by Dewstr1 View Post

Do you still have the box for a part #?
Nope, I threw it away as soon as I finished. Sorry man :x

Quote:
Originally Posted by tyback View Post

If you have a quick link to it please post it. Thank you.
No link, but all that was on the thread was text copied from somewhere else. Nonetheless it is easy to follow, and got me through it. Here:


Quote:
2003 SE, 28,000 miles.
Fan stopped working only on #2 position.
Replacement part #1-05139719AA. This is the "credit card" type resistor.
Cost me 16 US$ (with discount) from local dealer.
Plastic bag that part came in says "Made in USA", however, the part itself is marked "Made in Mexico". The old part was made in Mexico as well.

Blower Resistor: 4885456AB - $20.45
Switch: 5011214AA - $20.25

How to: This is what I did FWIW.

1. Disconnect negative battery terminal. My OEM radio did not lose it's station presets.

2. Remove passenger side door. Crawling around is just so much easier with the door removed and not banging on your legs. (OPTIONAL)

3. Remove glove box door.

4. Remove the screw attaching the under dash light on the passenger side (if you have a light there). Move the light out of the way. No need to unplug it.

5. Looking through the glove box opening, there is a large GREEN connector.
Unplug it and remove the bottom half from the heater box. Pull the bottom half down and out the bottom of the dash.

6. Now you can see and access the right side screw holding the resistor in.

7. Remove the two (8mm wrench) resistor screws. The left one from under the dash and the right one through the glove box opening.

8. Pull the resistor out of the heater box.

9. Unlock (the red thingy) the harness connector on the resistor and remove the resistor from the harness. Credit goes to an earlier poster for this excellent tip.

10. Plug in the new resistor and lock (the red thingy) the connector.

11. Assemble in reverse order.

This took me a little over an hour because the green connector gave me a hard time while trying to remove the bottom half from the heater box. You have to slide it up or down quite firmly to get it off. Do not pull straight out.
JReed615 is offline   Quote Quick Reply
Old 07-10-2013, 11:30 PM   #18226
Jeeper
 
MaxTurner's Avatar
 
Join Date: Jun 2012
Posts: 48
Today I installed new Kicker speakers for the soundbar, then changed the oil and gave her a bath and loaded it up onto the trailer to get ready to haul the jeep down to the beach! Good day overall.
MaxTurner is offline   Quote Quick Reply
Old 07-11-2013, 12:05 AM   #18227
Jeeper
 
Join Date: Jun 2013
Location: Saginaw, MI
Posts: 157
Send a message via Yahoo to twinge Send a message via Skype™ to twinge
did a little wheelin on request of a cute little 9 year old girl...





__________________
2005 Impact Orange TJ 4.0, 6spd - Hella 500ff's, MB Chaos 5's - gone

2009 Black Sahara JKU - Hella 500FF's on the pillars.
twinge is offline   Quote Quick Reply
Old 07-11-2013, 12:10 AM   #18228
Newb
 
ac28's Avatar
 
Join Date: Jun 2013
Location: New Jersey
Posts: 4
Thumbs up

Put clear parking and turn signals instead of amber, as well as the locking gas cap.
Attached Thumbnails
Click image for larger version

Name:	photo-30.jpg
Views:	82
Size:	219.7 KB
ID:	271278   Click image for larger version

Name:	photo-31.jpg
Views:	74
Size:	220.3 KB
ID:	271279  

ac28 is offline   Quote Quick Reply
Old 07-11-2013, 12:20 AM   #18229
Jeeper
 
Join Date: Feb 2013
Location: Lincoln, NE
Posts: 32
Got new skins on my baby...finally no more pizza cutters!

Click image for larger version

Name:	ForumRunner_20130711_001957.jpg
Views:	106
Size:	119.6 KB
ID:	271284
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20130711_002020.jpg
Views:	76
Size:	149.8 KB
ID:	271285   Click image for larger version

Name:	ForumRunner_20130711_002052.jpg
Views:	64
Size:	124.5 KB
ID:	271286  

JeepMan740 is offline   Quote Quick Reply
Old 07-11-2013, 12:23 AM   #18230
Jeeper
 
Rude Dog's Avatar
 
Join Date: Feb 2013
Location: Northern Calif
Posts: 5,129
They stick really good, even upside down...
__________________
2004 Wrangler Rubicon 4.0 w/Auto, 3.5" Rubicon Express Super Flex lift w/Currie Control Arms, RE Mono Tube Shocks, RE CV Drive Shaft, Engine/belly pan skid plate, Co2 Powertank. Hi Lift Jack.
Rude Dog is online now   Quote Quick Reply
Old 07-11-2013, 01:35 AM   #18231
Newb
 
smitty4's Avatar
 
Join Date: Jul 2013
Posts: 14
got my windows tinted 5%
Attached Thumbnails
Click image for larger version

Name:	IMG_6744.jpg
Views:	83
Size:	58.7 KB
ID:	271299  
__________________
ESJ
smitty4 is offline   Quote Quick Reply
Old 07-11-2013, 05:36 AM   #18232
Jeeper
 
tsteb's Avatar
 
Join Date: Apr 2012
Location: North Carolina coast
Posts: 915
Quote:
Originally Posted by hcarlgolden View Post

Looks good man. I have almost the same light setup, rear lights, KC lights on the hinges. I just need the hood light bar. Do you have better / day pics of the light bar?


Click image for larger version

Name:	image-439715794.jpg
Views:	199
Size:	161.4 KB
ID:	271320

Sorry it's so crappy haha. It's iPhone pics. And those lights are bright as hell
tsteb is offline   Quote Quick Reply
Old 07-11-2013, 06:40 AM   #18233
Jeeper
 
tyback's Avatar
 
Join Date: Apr 2013
Location: Jackson, KY
Posts: 125
Quote:
Originally Posted by JReed615 View Post
Nope, I threw it away as soon as I finished. Sorry man :x

No link, but all that was on the thread was text copied from somewhere else. Nonetheless it is easy to follow, and got me through it. Here:
Good deal. I priced one at a couple parts stores yesterday. Those in stock were $45. But they had one that was $21 that I had to order and wait a couple days to get. I hate when companies do that. It's no emergency so I think I will just try to find one on the Internet and order it myself. Besides I can get 15% off rt now online at advance auto parts.

Also yesterday,, I replaced the courtesy light switch on the drivers side. Finally realized this is why my lights left on indicator wasn't buzzing at work the other day when I got out and left my lights on and my battery had ran down at work! All is well now.
tyback is offline   Quote Quick Reply
Old 07-11-2013, 07:20 AM   #18234
Jeeper
 
patrickstarfox's Avatar
 
Join Date: May 2012
Location: winston-salem, NC
Posts: 717
fixed the engine-noise coming through the radio last night! after tearing all of the dash and stereo equipment apart, and re-grounding both amps, and running a heavier wire to the big amp for power, i found that the sub amp was causing the problem. if i unplugged it from the splitter, the noise dissapeared. as soon as i even got the aux jack close to plugging back in, the sound came back.

the solution ended up being a ground loop isolator. i didnt wanna do it, because thats kind of a band-aid fix, but i couldnt take that noise anymore. $20 later, its silent! i put the GLI in line between my phone and the big amp, and it filters out the noise.

now as soon as i figure out why BOTH of my turn signals are blinking fast, my jeep will be back to 100%
__________________
"seriously, what a pack of jackhandles...."

"In my experiences it really doesn't matter what materials you use, if you play in the rocks your undercarriage won't be as pretty as when you started."
patrickstarfox is offline   Quote Quick Reply
Old 07-11-2013, 08:03 AM   #18235
Jeeper
 
jherrington's Avatar
 
Join Date: Jan 2012
Location: Baton Rouge
Posts: 2,024
Quote:
Originally Posted by patrickstarfox View Post
fixed the engine-noise coming through the radio last night! after tearing all of the dash and stereo equipment apart, and re-grounding both amps, and running a heavier wire to the big amp for power, i found that the sub amp was causing the problem. if i unplugged it from the splitter, the noise dissapeared. as soon as i even got the aux jack close to plugging back in, the sound came back.

the solution ended up being a ground loop isolator. i didnt wanna do it, because thats kind of a band-aid fix, but i couldnt take that noise anymore. $20 later, its silent! i put the GLI in line between my phone and the big amp, and it filters out the noise.

now as soon as i figure out why BOTH of my turn signals are blinking fast, my jeep will be back to 100%
Usually try blink fast when you've got a turn signal light out, no?
__________________
98 TJ sport 4.0L I6 356,000 miles.
No Engine, axle, tranny, or t-case rebuilds.
Check out my 5.3 swap in progress here!
jherrington is offline   Quote Quick Reply
Old 07-11-2013, 08:13 AM   #18236
Jeeper
 
patrickstarfox's Avatar
 
Join Date: May 2012
Location: winston-salem, NC
Posts: 717
Quote:
Originally Posted by jherrington View Post
Usually try blink fast when you've got a turn signal light out, no?
right. but usually my turn signals will blink fast either left or right first thing in the morning when its cold, but then after about 5 minutes of driving and using the signals a few times, itll fix itself and go back to blinking normally. so that has me wondering if its a problem with the flasher.

but ill check all the bulbs tonight i guess...who knows. its been sitting for a month. maybe i had a bulb go out on both sides?
__________________
"seriously, what a pack of jackhandles...."

"In my experiences it really doesn't matter what materials you use, if you play in the rocks your undercarriage won't be as pretty as when you started."
patrickstarfox is offline   Quote Quick Reply
Old 07-11-2013, 10:01 AM   #18237
Jeeper
 
Join Date: Feb 2013
Location: Lincoln, NE
Posts: 32
Quote:
Originally Posted by Rude Dog View Post
They stick really good, even upside down...
Lol ya don't know what happened there...the pics are right side up on my phone but when I'm on my PC they upside down...
JeepMan740 is offline   Quote Quick Reply
Old 07-11-2013, 10:38 AM   #18238
Jeeper
 
patrickstarfox's Avatar
 
Join Date: May 2012
Location: winston-salem, NC
Posts: 717
i just had the best idea ever!
im gonna take the center speaker that i installed in my dash where the radio used to be, and disconnect it from the music. then im gonna make an adapter for it so that i can use it as a much better external speaker for my CB radio! then ill be able to get the stereo to sound balanced again, AND ill actually be able to hear people on the CB! how cool is that!?

(this is the speaker im talking about for those who are like "wtf?" haha)



now i really cant wait to get off of work today. that shouldnt take more than 10 minutes to get working and just in time for my trip to UNF this weekend!
__________________
"seriously, what a pack of jackhandles...."

"In my experiences it really doesn't matter what materials you use, if you play in the rocks your undercarriage won't be as pretty as when you started."
patrickstarfox is offline   Quote Quick Reply
Old 07-11-2013, 10:50 AM   #18239
Jeeper
 
elclipo's Avatar
 
Join Date: Jan 2013
Posts: 754
Washed it yesterday. Rained furiously immediately after
__________________
Semper Fi

Black Stallion Build
elclipo is offline   Quote Quick Reply
Old 07-11-2013, 10:53 AM   #18240
Jeeper
 
JReed615's Avatar
 
Join Date: May 2012
Location: Michigan
Posts: 700
Touched up a few scratches, dropped the stopped, and realized my front right fender has been repainted. I'm not sure why or when, but I hope it wasn't anything to serious

JReed615 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
One Problem After Another Today :( vin211 TJ General Discussion Forum 2 01-10-2014 09:42 PM
Officially a JEEP owner today rico334 TJ General Discussion Forum 24 12-17-2013 02:36 AM
Tops switch today mishel JK General Discussion Forum 4 06-23-2009 02:00 PM
Today is my Anniversary! jeeptales Off-Topic 13 04-03-2006 02:44 PM



» Featured Product

All times are GMT -5. The time now is 09:38 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC