What the!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-31-2013, 01:13 PM   #1
Jeeper
 
Join Date: Sep 2012
Posts: 111
What the!!

So my dash suddenly is freaking out on me the speedo and tach jump all over an none of the other gauges work. All the lights work though but the check engine light will flash on and off periodically any ideas what it could be?

James 98TJ is offline   Quote Quick Reply
Old 01-31-2013, 01:16 PM   #2
Jeeper
 
Timberline's Avatar
 
Join Date: Sep 2012
Location: 38.8339° N, 104.8208° W, Colorado
Posts: 1,135
Images: 2
Not sure if Wranglers are the same, but I had a previous vehicle do the same thing with my speedo and tach and it ended up being that my battery was going bad. I guess that was a sign that I needed to replace it soon.

__________________


2004 Sahara TJ
3.73 Gears / 4.0L / 2" Pro Comp Lift / BF Goodrich AT 32x11.50R15 / 15x8 Pro Comp Alloy Series 1059 / 4' Firestik Ant / Midland CB Radio / Roll & Pitch Clinometer / KC & Hella 700FF Driving Lights / Winch / Smittybilt Bumpers (modified)/ Teraflex 9550 SS
Timberline is offline   Quote Quick Reply
Old 01-31-2013, 01:23 PM   #3
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 1,785
Start with the easiest , cheapest remedy. Pull the dash cluster and clean the contacts and apply dielectric grease. Sometimes the erratic gauges are from poor/corroded contacts of the dash cluster. Try pushing on the dash to see if it resolves.
Wattapunk is offline   Quote Quick Reply
Old 01-31-2013, 02:47 PM   #4
Supporting Member

WF Supporting Member
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California/Montana
Posts: 3,131
Clean the contacts on the connections as said above, and while you are back there make sure the grounds are properly connected to the body and are free from corrosion or rust. Last, make sure your battery terminal connections are also clean and attached well. Let us know how it goes and we can go from there. Best of luck
__________________
--------------------------------------------------------
jeepwayoflife is offline   Quote Quick Reply
Old 01-31-2013, 02:51 PM   #5
Jeeper
 
Dextreme's Avatar
 
Join Date: Oct 2011
Location: Oregon City, OR
Posts: 3,488
Images: 1
My cluster has a spaztic tweakout about once a week. I should pull it it check the connection, but I am just used to it now.
__________________
'99 Chilli Pepper TJ Wrangler "Mistress"
33x12.5 DuraTracs
Zone 4.25"
Dextreme is offline   Quote Quick Reply
Old 01-31-2013, 05:16 PM   #6
Jeeper
 
Join Date: Sep 2012
Posts: 111
Pressed on the dash on the way home and everything came back to life do I need to pull the cluster and check the connections?
James 98TJ is offline   Quote Quick Reply
Old 01-31-2013, 06:13 PM   #7
Supporting Member

WF Supporting Member
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California/Montana
Posts: 3,131
Quote:
Originally Posted by James 98TJ View Post
Pressed on the dash on the way home and everything came back to life do I need to pull the cluster and check the connections?
Yep, sounds like something is shorting out or the connections are slipping out of place.
__________________
--------------------------------------------------------
jeepwayoflife is offline   Quote Quick Reply
Old 01-31-2013, 06:44 PM   #8
Jeeper
 
viperx6x9x's Avatar
 
Join Date: Dec 2012
Location: Norfolk Va.
Posts: 1,075
This was another vehicle but I had a similar spas out happen in my Silverado.

It was preceded by a "battery not charging" message in the info center so I should have known alternator in the first place.

anyway later on in the drive all the sudden all the guages would start flashing on and off, and the guages would jump up and down as the alternator worked in spurts. And then it all died completely.

If you look at your battery guage, does the needle sit a little lower than it usually does? Mine usually sits at 14volt, but at the time this was happening it was sitting at 12.

I don't know if 98's had a message center, but in the absence of one it could possibly throw a check engine light instead.

It could be a lot of things, but alternator jumps to mind from what my truck did.
viperx6x9x is offline   Quote Quick Reply
Old 01-31-2013, 10:30 PM   #9
Jeeper
 
Join Date: Sep 2012
Posts: 111
Thanks for the reply's I really think its a short if I push on the cluster the check engine light comes on an so does the airbag light guessing loose connection
James 98TJ is offline   Quote Quick Reply
Old 01-31-2013, 10:58 PM   #10
Jeeper
 
viperx6x9x's Avatar
 
Join Date: Dec 2012
Location: Norfolk Va.
Posts: 1,075
In that case like wattapunk said, pull the cluster. One by one clean up those connections. Check for loose ones. Look for corrosion too, common cause of shorts.

If you need help, heres a thread on swapping out the led's in the cluster. There's instructions in there somewhere on getting the gauge cluster out.

http://www.wranglerforum.com/f5/tj-d...eap-91949.html
viperx6x9x is offline   Quote Quick Reply
Old 01-31-2013, 11:30 PM   #11
Jeeper
 
Phil.Dye's Avatar
 
Join Date: Mar 2012
Location: Santa Maria, CA
Posts: 145
Pull, clean and reinsert. While you're at it you can make sure all your wires back there and neat and tidy.

Phil.Dye is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC