where is my hazard flasher 97 tj - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-07-2012, 09:06 PM   #1
Jeeper
 
pastorscott's Avatar
 
Join Date: Dec 2010
Location: Long Island NY
Posts: 389
where is my hazard flasher 97 tj

my hazard flashers dont work. any suggestions on what could be wrong and if its the flasher where is it located

thanks guys
p.scott

pastorscott is offline   Quote Quick Reply
Old 08-07-2012, 10:51 PM   #2
Jeeper
 
Hums99's Avatar
 
Join Date: Mar 2012
Location: NW PA
Posts: 354
According to some research it is located on top the steering column under the plastic. Hope this helps mine doesnt work either, now I have to fix it now that you made me look for it. LOL

__________________
Keep on Jeepin' * lllllll *

Here's my build: http://www.wranglerforum.com/f118/re...ld-262041.html
Hums99 is offline   Quote Quick Reply
Old 08-07-2012, 11:36 PM   #3
▄▌ee▐▀

WF Supporting Member
 
Hardermods's Avatar
 
Join Date: Jul 2009
Location: Kansas
Posts: 1,315
Under the dash, near the steering column



Remove the lower steering column cover and knee blocker NOTE: The combination flasher and flasher mounting bracket are serviced only as a unit.

Reach through the inboard side of the steering column opening and remove the screw securing the combination flasher and mounting bracket to the upper steering column mounting bracket.
Unplug the combination flasher and bracket from the wiring connector.
To install the flasher, align the terminals with the cavities in the connector and push the flasher firmly into place.
Reinstall the screw securing the flasher and mounting bracket to the upper steering column mounting bracket.
Reinstall the knee blocker and steering column cover
Hardermods is online now   Quote Quick Reply
Old 08-08-2012, 12:01 AM   #4
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,315
If the turn signals work, the flasher (same for both) is good. Most likely it is the switch. Try moving the switch on & off a bunch of times. Since the flashers don't get used very often the contacts can get "dirty". Working it can clear those contacts. Otherwise you may try getting some contact cleaner in there then working it.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 07:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC