Wiper electrical issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-07-2012, 08:33 AM   #1
Jeeper
 
Join Date: Jun 2011
Location: Northern Maine (way past the Moose !!!)
Posts: 76
Question Wiper electrical issue

Just went out today and found that my wipers are dead. I have wiper pump working but the wipers themselves are dead in all positions. I swapped out the fuse ( # 14 ) but it did no good. The magic question therefore, is the wiper motor gone and need replacing, and if so, how tough to do it and the likely cost ?

I'm up here in North Maine and we are looking at an ice / snow storm over the next 48 hours (Sat to Monday) so time, as such, is a factor. Any one have any ideas, please, don't be shy !

retired04497@gmail.com

Old Grunt is offline   Quote Quick Reply
Old 01-07-2012, 09:54 AM   #2
Jeeper
 
Join Date: Apr 2011
Posts: 18
Old Grunt,
Try this link I think 2KwranglerTJ was having the same issue:

Windshield wiper motor - JeepForum.com

dproctor0715 is offline   Quote Quick Reply
Old 01-07-2012, 10:12 AM   #3
Jeeper
 
GriffsTJ's Avatar
 
Join Date: Jul 2011
Location: Lanesboro, MA
Posts: 59
Did it give any sign of going out before it finally did. Mine made horrible noises until it finally died. To replace it it isnt too bad. The biggest problem i came across was unplugging it rather then putting a new one in. Good luck.
__________________
01 XJ 3" lift with 31's
98 TJ 4" lift with 33's
GriffsTJ is offline   Quote Quick Reply
Old 01-07-2012, 02:10 PM   #4
Jeeper
 
Join Date: Jun 2011
Location: Northern Maine (way past the Moose !!!)
Posts: 76
Unhappy Wiper

Griff, not a sound. It just quit. The pump still works but nothing else. Any idea as to just how supposedly 'easy' it is to replace the motor. The only book I have to go by is an old Haynes manual. And I just tried a 3rd fuse. Still DOA.
Old Grunt is offline   Quote Quick Reply
Old 01-07-2012, 02:55 PM   #5
Jeeper
 
Badass_TJ's Avatar
 
Join Date: Jul 2011
Location: Maine
Posts: 412
just went thru this last week with mine, my wiper motor was rotted all the way thru, it was a 100 bux at napa with core. very easy to change, pull out the three bolts and the entire wiper transmission and motor all comes out. just a tip when you get the new motor plug it in first and make sure it works, the first one i got from napa was junk.
Badass_TJ is offline   Quote Quick Reply
Old 01-07-2012, 03:23 PM   #6
Jeeper
 
calkid's Avatar
 
Join Date: Dec 2011
Location: Hesperia, Ca
Posts: 56
Mine quit on an off road trip in the snow. I ended up pulling the plastic cover off of the steering column and found a connector unplugged. Must have vibrated loose on the rough trails.
calkid is offline   Quote Quick Reply
Old 01-11-2012, 07:07 AM   #7
Jeeper
 
Join Date: Jun 2011
Location: Northern Maine (way past the Moose !!!)
Posts: 76
Talking Wiper Motor issue !

Spent better part of yesterday AM in the shop with my mech'. Took the cowl cover off and he 'jump'ed' the wiper motor to another ground. Guess what ? It came back PDQ ! Seems that the motor's ground has a tendency, with mine, to corrode and eventually die. Many thanks for the help. Hope this keeps someone else from growing gray hair like I did !!!

Old Grunt is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 electrical issue? jyeast TJ General Discussion Forum 5 12-15-2011 06:52 PM
Electrical issue help needed xxxxxxdonno151 TJ General Discussion Forum 2 10-06-2011 08:46 PM
Rear wiper and defrost issue jpm1609 TJ Tech Forum 0 12-06-2009 03:16 PM
Electrical issue kg4kpg TJ Tech Forum 6 05-16-2009 09:21 PM
electrical issue khenderson TJ Tech Forum 2 09-15-2005 04:38 PM



» Featured Product

All times are GMT -5. The time now is 08:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC