Won't run - sometimes - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-02-2006, 05:04 PM   #1
Newb
 
Join Date: Jul 2006
Posts: 3
Won't run - sometimes

I have a 98 wrangler with 2.5 that won't run sometimes. I thought it was the fuel pump after putting gas in the intake and it fired immediately. I pulled the tank and there is a filter on top. I tried to blow through it and it seemed restricted. However, I put it back together and it ran. Put tank back in and it ran for three days and then let me down. Now I have the tank out and hooked up the fuel line and electrical and it seems to run every time. I hate to replace with the cost being so high. Any help is really appreciated.

wfromm is offline   Quote
Old 07-02-2006, 05:49 PM   #2
Newb
 
Join Date: Jul 2006
Posts: 3
wfromm

guys, after looking around the website, I'm wondering if it could be the Crankshaft Position Sensor. When the engine stops, it cuts out like its electrical. No sputter, etc. Please help, sure would like to get this thing reliable. Thanks.

wfromm is offline   Quote
Old 07-02-2006, 07:39 PM   #3
Shake 'n Bake

WF Lifetime Member
 
khenderson's Avatar
 
Join Date: Apr 2005
Location: PHX
Posts: 1,344
Send a message via ICQ to khenderson Send a message via AIM to khenderson Send a message via Yahoo to khenderson
i know on my 97 that before i got it, it was having problems running and starting and the previous owner replaced the fuel pump and it's been good to me since i've had it. seems like i was told there was a TSB out about the fuel pumps in the early years of the TJ's. i could be mistaken though.
__________________
I'ma come at your like a spider monkey!


khenderson is offline   Quote
Old 07-02-2006, 08:09 PM   #4
Newb
 
Join Date: Jul 2006
Posts: 3
thanks

thanks, khenderson for the response. I'm probably reading more into this than I should. I am going to check the fuel pump pressure tomorrow and will probably end up replacing the pump. In other posts, I read that the filter at the top of the pump assembly is a lifetime unit so I prob won't replace the whole assembly. This is a great forum. thanks again.
wfromm is offline   Quote
Old 10-21-2007, 10:44 PM   #5
Jeeper
 
ftamboner1204's Avatar
 
Join Date: Jul 2007
Location: West Chester, Pennsylvania.. Moving to New Castle,Delaware in near future
Posts: 40
Send a message via MSN to ftamboner1204 Send a message via Yahoo to ftamboner1204
I have a 94 wrangler 2.5 , have had issues on this back and forth up and down, now when I felt all was fixed.It won't start, now here is the kicker, fuel pump has been replaced in july.. i do believe this is not the issue here is what is funny,if I continue to crank over to start,,no i get no spark and sometimes "" i get no fuel cause relay doesnt want to start but then does,, ok well right before it dies from battery draining down, it wants to start,,,,,EVERYTIME!!! but it wont try to start when the battery is fully charged,,, now throw that one around some.. all help is greatly appreciated
ftamboner1204 is offline   Quote
Old 10-22-2007, 09:56 AM   #6
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
I had an 89 yj 4.2 5sp about 10 years ago with similar problem. It would cut out intermittently, sometimes it would restart right away sometimes it would take a while. I replaced fuel pump, fuel filter, dist. cap and wires, ignition module etc. Finally swallowed my pride and took it to the dealer, it ended up being a bad coil. Dealer said that it was fairly common w/jeeps, don't know if that is still true, just a thought.

__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:13 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC