Wont start question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-19-2011, 06:01 PM   #1
Newb
 
Join Date: Dec 2010
Posts: 11
Wont start question

Just put a new 4.0 in my Rubicon. Everything is hooked up and installed properly and too specs. Go to turn the key and it turns over but nothing happens. Any tips or advice what to check? Thanks

maximus_12-12 is offline   Quote Quick Reply
Old 02-19-2011, 06:10 PM   #2
Jeeper
 
Rubicon2's Avatar
 
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
Quote:
Originally Posted by maximus_12-12
Just put a new 4.0 in my Rubicon. Everything is hooked up and installed properly and too specs. Go to turn the key and it turns over but nothing happens. Any tips or advice what to check? Thanks
What did you transfer over to the new engine that wasn't on the new engine?

__________________
DO OR DO NOT... THERE IS NO TRY.
Rubicon2 is offline   Quote Quick Reply
Old 02-19-2011, 06:22 PM   #3
Jeeper
 
Black98's Avatar
 
Join Date: Nov 2010
Location: South East PA
Posts: 379
well if it turns that means starter+battery are fine, Check the entire ignition and fuel systems.
Black98 is offline   Quote Quick Reply
Old 02-20-2011, 07:46 PM   #4
Newb
 
Join Date: Dec 2010
Posts: 11
It's a long block so everything was pretty much swapped over. Its getting fuel and seems to back fire like the timing may be off some how
maximus_12-12 is offline   Quote Quick Reply
Old 02-20-2011, 07:59 PM   #5
Jeeper
 
Rubicon2's Avatar
 
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
What year? Your cam sensor could be off from where it is suppose to be.
__________________
DO OR DO NOT... THERE IS NO TRY.
Rubicon2 is offline   Quote Quick Reply
Old 02-20-2011, 08:04 PM   #6
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,369
Images: 2
How is the crankshaft position sensor? Do you have it positioned and spaced away from the flywheel or flex plate properly?
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-20-2011, 08:46 PM   #7
Jeeper
 
Rubicon2's Avatar
 
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
Quote:
Originally Posted by Jerry Bransford
How is the crankshaft position sensor? Do you have it positioned and spaced away from the flywheel or flex plate properly?
I didn't think of that one. Good call.
__________________
DO OR DO NOT... THERE IS NO TRY.
Rubicon2 is offline   Quote Quick Reply
Old 02-21-2011, 07:48 PM   #8
Newb
 
Join Date: Dec 2010
Posts: 11
Got it to start, cam position sensor needed adjusting. now the issue I'm having is when it starts it over revs. Any suggestions there?
maximus_12-12 is offline   Quote Quick Reply
Old 02-21-2011, 07:55 PM   #9
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,369
Images: 2
Over-revving means the engine is getting too much air into the combustion chambers. That can be caused by a vacuum leak or the intake manifold not being properly seated against the head. Since you just installed a new engine, I strongly suspect the intake manifold is not properly seated and is leaking air into the engine from where it is attached to the head. There are two small positioning studs that the intake manifold must be precisely positioned over before the bolts can be tightened.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 02-21-2011, 09:08 PM   #10
Newb
 
Join Date: Dec 2010
Posts: 11
I will double check that tomorrow. thanks

maximus_12-12 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAQ's-jeep wont start! speepdaedeesi TJ Tech Forum 20 05-29-2010 11:28 PM
USS Never Start - but it wants to...and so do I anklenawer YJ Tech Forum 11 02-03-2010 08:06 PM
Where to start... mspencer54 YJ General Discussion Forum 2 03-04-2009 08:59 PM
wont start cold?! Mikeyz89YJ YJ Tech Forum 2 02-14-2009 09:14 AM
How flammable is a tj? (My jeep doesnt start) lost TJ Tech Forum 20 02-22-2008 07:15 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC