Extremely High Oil Pressure? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-06-2006, 12:21 PM   #1
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Extremely High Oil Pressure?

Im not sure if any of you wrangler guys had the same problem. I have a 95' Wrangler and my oil pressure is extremely high...to the point whre im almost maxing out the oil pressure gage. Is this normal for jeeps to do? I tried changin my oil thinking it would go down but it hasnt. I just want your guys opinions on what to do and if this usually happens to jeeps Thanks

--Mike

__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-06-2006, 12:54 PM   #2
Jeeper
 
naviathan's Avatar
 
Join Date: Oct 2005
Location: Eastern NC
Posts: 145
Send a message via Yahoo to naviathan
Change your pressure sensor. When they get old they read high pressure all the time.

__________________
SOLD - Maybe I can afford this game when I'm old an rich.
naviathan is offline   Quote Quick Reply
Old 02-06-2006, 01:11 PM   #3
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Seems easy enough...Thanks for the input
__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-06-2006, 07:42 PM   #4
Gets stuck on escalators
 
Join Date: Dec 2005
Location: Springfield, NJ
Posts: 74
Hopefully it is the oil sending unit. I'm basically new to the Jeep world, but not to the automotive world. I have seen several engines running very high oil pressure due to plugged oil passages. Most of the time flushing the engine resolved the issue but not always. Getting back to what I said before... hopefully it is the oil sending unit.


Frank
Fapple is offline   Quote Quick Reply
Old 02-07-2006, 06:44 AM   #5
Jeeper
 
naviathan's Avatar
 
Join Date: Oct 2005
Location: Eastern NC
Posts: 145
Send a message via Yahoo to naviathan
I've seen this a lot on the Jeeps and it's always been the sending unit. I'd be surprised if it wasn't.
__________________
SOLD - Maybe I can afford this game when I'm old an rich.
naviathan is offline   Quote Quick Reply
Old 02-07-2006, 09:28 AM   #6
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Okay, thanks guys...Ill let you know how things turn out once i buy a new sending unit
__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-07-2006, 04:56 PM   #7
Jeeper
 
R.P.M.'s Avatar
 
Join Date: Dec 2005
Location: GRAND RAPIDS MI
Posts: 58
Oil pressure

when you pickup your sending unit about $30 something if I remember right, they sell a special socket to install. At least
its easy to get to. Our had ruptured months before we bought
the jeep so we had quarts of oil down the block and all over thepad and tranny.
R.P.M. is offline   Quote Quick Reply
Old 02-11-2006, 08:22 PM   #8
Newb
 
Join Date: Jan 2006
Posts: 11
we get great oil pressure every time we turn the key to on yep its a jeep thing
jp4ever is offline   Quote Quick Reply
Old 02-12-2006, 06:45 PM   #9
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Well the unthinkable happened and im not sure if it was because of the oil pressure but while i was waiting inline for gas (6 min.) at idle my car suddenly over heated. Smoke is coming out from under the hood and when i moved my car i saw there was a huge puddle of what i believe was coolant. Is it possible that under the heat, the pressure built up so much it spit out some coolant? It didnt come from the radiator tho...There are a bunch of wet marks by the engine coolant resivore and thats where it was mostly steaming from......? I have no idea what happened....Do you? (by the way, i still didnt buy a new sender unit for the oil pressure, so yea it is still running high but then after 15 min. of driving it comes close to normal but not just quite yet)
__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-12-2006, 08:01 PM   #10
Jeeper
 
Join Date: Jan 2006
Posts: 74
Quote:
Originally Posted by BigMike
Well the unthinkable happened and im not sure if it was because of the oil pressure but while i was waiting inline for gas (6 min.) at idle my car suddenly over heated. Smoke is coming out from under the hood and when i moved my car i saw there was a huge puddle of what i believe was coolant. Is it possible that under the heat, the pressure built up so much it spit out some coolant? It didnt come from the radiator tho...There are a bunch of wet marks by the engine coolant resivore and thats where it was mostly steaming from......? I have no idea what happened....Do you? (by the way, i still didnt buy a new sender unit for the oil pressure, so yea it is still running high but then after 15 min. of driving it comes close to normal but not just quite yet)

Why were you waitning for gas for 6minutes?
thats seems like a really long time.
__________________
Revolution Rotorsports
71 Mazda RX2
88 Mazda 323 GTX -rally machine in progress
93 Ford shitbox Ranger.

Looking for a Jeep
matt22 is offline   Quote Quick Reply
Old 02-12-2006, 08:27 PM   #11
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
I think you need to replace your thermostat and change all of your raidator hoses. Probably wouldn't hurt to get your radiator pressure tested at the same time.
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 02-12-2006, 08:29 PM   #12
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Quote:
Originally Posted by matt22
Why were you waitning for gas for 6minutes?
thats seems like a really long time.
Where do you get your gas? It takes longer than six minutes for me to pump gas and pay for it. You must never have to wait behind anyone.
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 02-13-2006, 07:12 AM   #13
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Quote:
Originally Posted by amerijeep
Where do you get your gas? It takes longer than six minutes for me to pump gas and pay for it. You must never have to wait behind anyone.
BJ's has the cheapest gas around. Because of the snowstorm the line was absolutely huge. A six minute wait was not bad at all....People were waiting for 10+ min.
__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-13-2006, 05:28 PM   #14
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Quote:
Originally Posted by amerijeep
I think you need to replace your thermostat and change all of your raidator hoses. Probably wouldn't hurt to get your radiator pressure tested at the same time.
My vote is on this too. Doesn't sound like the tstat is opening correctly all of the time.
__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 02-13-2006, 06:11 PM   #15
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Quote:
Originally Posted by 1BLKJP
My vote is on this too. Doesn't sound like the tstat is opening correctly all of the time.

Right. I also had a situation once on my old 4X4 Dakota where the inside of the radiator hose was collapsing on the inside when it got hot. You couldn't see it from the outside. I've been told this is fairly common but I have only had it happen to me once. Not really sure how common it is.
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 02-14-2006, 04:41 AM   #16
Jeeper
 
3jeepguy's Avatar
 
Join Date: Aug 2005
Location: upstate ny
Posts: 119
very common they do that just before the rupture
__________________
95 yj 4.0 4 inch bds and 1.5 shackle lift 33inch swampers for summer and 32 inch mudkings for winter 8500# milemarker winch and homemade high lift / light mount on hood

|||||||
3jeepguy is offline   Quote Quick Reply
Old 02-14-2006, 09:33 AM   #17
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
Any idea why it spit out fluid? Im not sure if a faulty themostat would do that...but then again, im not too sure...Im having trouble finding out where it spit out all the fluid from also...I think its somewhere in the general area of the back of the engine compartment...near the master cylinder
__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Old 02-15-2006, 08:05 PM   #18
Supporting Member

WF Supporting Member
 
daddyjeep's Avatar
 
Join Date: Apr 2005
Location: Smethport, PA
Posts: 2,229
The only thing I can of that would make the fluid spew out of the overflow is if the rest of the system is sealed up really well. Whn the pressure builds up due to the overheating it has to escape somewhere. Actually, That is the purpose of the cap, to release excessive pressure. You most likely need a cap. It must be frozen up. Like said above, get a thermostat and a new cap and see how things go.
__________________
87 YJ, 5.2/46RH/NP231, Custom 4 link/ Radius Arms, Ballistic Nitrogen Shocks, 35" Cooper STT DaddyJeep build Thread:http://www.wranglerforum.com/f8/dadd...ld-122601.html
daddyjeep is offline   Quote Quick Reply
Old 02-26-2006, 06:51 PM   #19
Jeeper
 
mmasuperman12's Avatar
 
Join Date: Dec 2005
Location: York, ME
Posts: 466
Send a message via AIM to mmasuperman12
opposite end of the spectrum

last night we got about a foot of snow and me and a few buds decided to go do some donuts down at the local highschool parking lot. all gauges were normal at the start but near the end of all of it i looked down whil idleing and my oil pressure was about 20-25 but as soon as i step on the gas it goes back up, checked the oil and it looked fine and looked to see if i could see any coming out of anywhere and on the ground couldnt find anything. any ideas? ill say it was worth it and seein the local police was too.
__________________
95 wrangler 4banger 5.25 " of lift sittin on 33's black steel rims Gone But not Forgotten


Tow Vehicle: 2003 GMC 2500HD duramax 6.6, 4 inch turbo back magnaflow exhaust, tow mirrors, 285/75/16 BFG A/T's Westin brush guard and steps, leer cap, K&N intake, Sirius sat. radio



dont waste your money on junk lifts, save a few extra pennies and get something good.
mmasuperman12 is offline   Quote Quick Reply
Old 03-05-2006, 05:13 PM   #20
Jeeper
 
Join Date: Sep 2005
Location: Connecticut
Posts: 85
Send a message via AIM to BigMike
mmasuperman12--I also have this problem...But for me..My oil pressure is only high while my engine is cold...I replaced the thermostat and got a new cap for my radiator and all is fine i must say.

To everyone else--Thanks for helpin me out guys

__________________
95' Wranger
6 cyl. 4.0 L

1 ton YJ
BigMike is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High oil pressure jeepnewbie YJ Tech Forum 9 08-04-2010 09:40 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 09:26 PM
Oil Pressure High??? bobdog TJ Tech Forum 5 10-09-2007 09:31 AM
High oil pressure question Demodave TJ Tech Forum 3 06-01-2007 09:57 AM
high oil pressure! HELP!!! matty0335 TJ Tech Forum 7 10-20-2006 04:03 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC