failed emssions with O2 sensor reading lean Help! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 04-21-2010, 06:29 PM   #1
Join Date: Jan 2010
Posts: 6
failed emssions with O2 sensor reading lean Help!

So I have a 1993 YJ with the 2.5. I have failed emssions a few different times for High CO and High HC. and am hoping for a few ideas.

Test 1: Failed for high HC Reading 2.69, limits are 2.5. Hooked it up to the sun maching and discovered the cat wasnt lighting off so I replace it. (previous owner had punched it out)

O2 sensor was reading a negative voltage of -0.2 to -0.8
Replace 02 sensor, spark plugs, fuel filter, airfilter, cap and rotor, removed throttle body and cleaned that as well as the intake and no vacuum leaks.
(all for good measure)

Test 2: Failed for high CO Reading was 27.6 and limits are 25.

all the numbers on the scope machine are well below the limits ie, snap throttle, idle, and 2500rpm

the only thing i it seems i have issues with is under decel, the engine goes full rich, causing the reading to spike and HC goes through the roof. I tried multiple O2 sensor, yet the reading still read the -0.2 through -0.8 If I unplug the O2 sensor the check engine light does not illumaniate, with engine on.

Im thinking computer. any ideas

pyro826 is offline   Quote
Old 04-22-2010, 11:50 AM   #2
Founder, ThumbJeeps

WF Supporting Member
sevenservices's Avatar
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
don't know if it would matter but, is there a chance you could remove your air filter or replace with a high-flow just to pass the test? More air = less gas in the mix ratio.

Its not the root of the problem, but the only thing I can think of based on decel

Founder, ThumbJeeps

1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote
Old 04-22-2010, 01:09 PM   #3
carlyj's Avatar
Join Date: May 2009
Location: Las Vegas, NV
Posts: 180
if its a manual trans, run it real hard through 1-3 gear, then test it.
carlyj is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine lean code achappy44 TJ Tech Forum 2 12-18-2009 01:59 AM
Failed Ohio E Check PiTRiFF YJ General Discussion Forum 2 07-01-2009 08:16 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:07 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC