Horn Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-01-2006, 06:13 PM   #1
Jeeper
 
timmy43410's Avatar
 
Join Date: Sep 2006
Location: Northwest Ohio
Posts: 32
Send a message via Yahoo to timmy43410
Horn Problem

As long as I have owned my yj, the horn hasn't worked. It was never a problem until today. I needed to alert a dumbass that his driving skill were below par. When I push on the middle of the steering wheel it just sorta wobbles. Maybe its stuck? My guess is this is were the problem is since it doesnt move in or out. The horn under the hood is in good shape and the wiring looks fine too. How do I pull that piece off the middle of the steering wheel? I pried on it a little w/ a screwdriver, but didnt want to bust it so I stopped. Please help in case there are more people out there that need a reminder that I had the lane first...thanks!!!

timmy43410 is offline   Quote Quick Reply
Old 10-01-2006, 07:53 PM   #2
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Hav eyou checked your fuses? You can meter the power at the horn, but you'll have to get someone to push the horn for you. You can also check power at the fuse box easily. An easy way to see if your horn works at all is to run power directly to it from the battery to see if it sounds.

__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 10-02-2006, 08:14 PM   #3
Jeeper
 
timmy43410's Avatar
 
Join Date: Sep 2006
Location: Northwest Ohio
Posts: 32
Send a message via Yahoo to timmy43410
Ya, I have power and the fuse is good. Im sure its the switch. I was hope to pull it off clean it or replace it but was unsure how to yank it off.
__________________
"Man who stands on toliet is high on pot" TIMMY!!!!
timmy43410 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 02:03 AM
New Horn Alpha 9.5 Fast Winch from Autria nicolas-eric General Jeep Discussion 1 07-13-2008 10:50 PM
Shifting Problem lonerider6 YJ Tech Forum 6 06-01-2008 04:51 PM
2002 TJ Horn problem DiPietro TJ Tech Forum 14 03-23-2008 12:29 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC