SBC Conversion Overheat problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-10-2009, 09:48 AM   #1
Newb
 
Join Date: Feb 2009
Posts: 3
SBC Conversion Overheat problem

I just finished my SBC conversion in my 90 YJ and have an overheat problem. At idle my taurus efan on low does fine cycles and holds temp well. Once I get to 55mph after about 5 min I start to overheat temps up to 240. I would have thought with more air through the radiator at hwy would actually work for me. Any one have ideas on what to check.

1990 YJ
350 SBC
TH350
Taurus E-Fan
NP231
3 core conversion radiator (from racewayparts.com All Metal Heavy Duty 3 Row Radiator)

rmorrison9773 is offline   Quote Quick Reply
Old 08-10-2009, 01:02 PM   #2
Newb
 
Join Date: Mar 2008
Posts: 11
Do you have a shroud on the radiator? You will overheat without a shroud.

Is the radiator large enough? IIRC the rule of thumb is 50+ square inches of radiator surface MORE than the cubic displacement of your engine, e.g. For a 350 you need 400 square inches of radiator.

Root Moose is offline   Quote Quick Reply
Old 08-10-2009, 09:52 PM   #3
Jeeper
 
Join Date: Apr 2009
Posts: 538
240 is getting up there. where is your timing set? what exhaust are you running? what are your carb settings? what waterpump?

does the lower hose collapse when revving? lots of things to look at
dooder is offline   Quote Quick Reply
Old 08-11-2009, 03:18 PM   #4
Jeeper
 
Gaducker's Avatar
 
Join Date: Jul 2009
Location: Newnan
Posts: 225
Is it a vortec? reverse rotation water pump????
Gaducker is offline   Quote Quick Reply
Old 12-10-2009, 06:41 PM   #5
Newb
 
TookieOne's Avatar
 
Join Date: Dec 2009
Posts: 6
i have a 350 in my 1990 yj and im running the stock radiator without any overheating problems...i did notice that the bottom hose was collapsing so i made a new line from some header pipes and that solved it all but i am also running an electric fan along side a flex fan but only on really hot **** days. Like Dooder said check the bottom hose
TookieOne is offline   Quote Quick Reply
Old 12-10-2009, 09:45 PM   #6
Jeeper
 
uplifted's Avatar
 
Join Date: Aug 2009
Location: NY
Posts: 593
I'd go with insufficiant water pump flow... Hell i'm running 10.1 compression, 12 degrees of timing and i can't get my temp over 160... and thats with a 45 minute, 3000 rpm non stop parkway ride.... post up some pics of your set up so we can see what your working with..
__________________
91 YJ, SBC V8, 5 speed, 8.8, 4" spring, SOA, 35" MT/R ............ Sadly I have sold my Jeep.
uplifted is offline   Quote Quick Reply
Old 12-10-2009, 10:35 PM   #7
Jeeper
 
uplifted's Avatar
 
Join Date: Aug 2009
Location: NY
Posts: 593
Christ, just relized how old this thread was... ..i got sucked in
__________________
91 YJ, SBC V8, 5 speed, 8.8, 4" spring, SOA, 35" MT/R ............ Sadly I have sold my Jeep.
uplifted is offline   Quote Quick Reply
Old 12-11-2009, 12:50 PM   #8
Newb
 
TookieOne's Avatar
 
Join Date: Dec 2009
Posts: 6
Yeah oops I didn't even look

TookieOne is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
05 tj rattle problem fixed. JeepGuyLJ TJ General Discussion Forum 2 05-25-2011 01:00 PM
My SOA Conversion Plan; please critique. . . atomicjoe23 YJ Tech Forum 56 07-13-2009 02:22 PM
different transmission problem greasem0nkey86 YJ Tech Forum 5 03-26-2007 03:31 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC