something diffrent every week! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-12-2011, 02:16 PM   #1
Jeeper
 
Join Date: Aug 2011
Posts: 67
something diffrent every week!

so after replacing ingnition switch,pos battery cable and running fine for a few weeks the thing wont stay running! the only way i can get it to start is if i floor the gas pedal and then it runs like crap and the whole dam car shakes almost like water is in the gas i have no idication of rpms while its running and the check engine light flashed for a bit then stop but still comes on.

would you say its the fuel filter casue thats what im leaning towards?!

Hockeymutt is offline   Quote Quick Reply
Old 09-12-2011, 02:18 PM   #2
Jeeper
 
Join Date: Aug 2011
Posts: 67
also i hear the fuel pump turning on and starter is fine... im almost 99% sure im getting spark cause it will run with the gas pedal floored its just not getting fuel

Hockeymutt is offline   Quote Quick Reply
Old 09-12-2011, 03:09 PM   #3
Jeeper
 
Join Date: Aug 2011
Location: Utah
Posts: 88
Our 94 acted similarly and it was a bad fuel pressure regulator. Fuel was leaking past the diaphram down into the intake. This put it in a flooded condition and required you to mash the pedal (open throttle body) to get it to fire. This was after we replaced the fuel pump, fuel filter, and TPS. It ran fine for a week following those replacements ... then the regulator crapped the bed.
Pull the vacuume lines of the regulator ... if there's gas there ... it's bad.

BUT ours ran fine once it started and stumbled for a minute. The regulator only made it hard to start.
__________________
Location: 3 Hours from Little Sahara Dunes
4 Hours from St. Anthony Dunes
4.5 hours from MOAB
DamnBigPapa is offline   Quote Quick Reply
Old 09-12-2011, 03:37 PM   #4
Jeeper
 
Join Date: Aug 2011
Posts: 67
thanks for the reply am gonna give that a try! just went out and started right up was running a little rough gave it a little gas ran rough then started running fine put 5 gal of 90 in it and a bottle of iso treat and runs again maybe water in the gas?

now my belt squeals like a pig just changed it 3 weeks ago! should i tighten it back up? or is a bearing going bad, its also raining out and the squeal will stop after it revs up a lil
Hockeymutt is offline   Quote Quick Reply
Old 09-12-2011, 03:54 PM   #5
Jeeper
 
Glenn91YJ's Avatar
 
Join Date: Jul 2010
Location: MA
Posts: 345
Quote:
Originally Posted by Hockeymutt View Post
thanks for the reply am gonna give that a try! just went out and started right up was running a little rough gave it a little gas ran rough then started running fine put 5 gal of 90 in it and a bottle of iso treat and runs again maybe water in the gas?

now my belt squeals like a pig just changed it 3 weeks ago! should i tighten it back up? or is a bearing going bad, its also raining out and the squeal will stop after it revs up a lil
New belts stretch some after they are installed. Plus with the rain it will make it worse. I'm sure if you check the tension it will be a little loose.
__________________
Owning a Renegade means being "Different"!
Glenn91YJ is offline   Quote Quick Reply
Old 09-12-2011, 04:50 PM   #6
Jeeper
 
Vermonter's Avatar
 
Join Date: Jul 2011
Posts: 85
how long has it been since your fuel filter has been replaced? When I got my 89 the fuel filter looked like it hadn't been replaced ever. I was just a pile of rust that the fuel went threw on its way to the injector. I replaced that and my hard starting issues went away.
Vermonter is offline   Quote Quick Reply
Old 09-13-2011, 02:38 AM   #7
Jeeper
 
Join Date: Aug 2011
Posts: 67
On the fuel filter just bought the car in July been on my list of things to do will get to it soon tho! Tightened up my belt and the squeal went away! Thanks guys for all the help!

Hockeymutt is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no door for week trip? fan of fanboys Off-Topic 6 06-12-2011 07:16 PM
Woo hoo, 3 day week Bazzer Off-Topic 5 04-26-2011 04:07 PM
Genright Turkey Week in Johnson Valley 1BLKJP Trail Pics 24 12-04-2009 01:06 AM
bad week..... rebelBullDawg325 Off-Topic 11 09-22-2009 05:08 PM
Busy Week Dare2BSquare Off-Topic 12 07-08-2009 10:41 AM



» Featured Product

All times are GMT -5. The time now is 08:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC